summaryrefslogtreecommitdiff
path: root/dev-python/argcomplete
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-13 16:26:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-13 16:26:20 +0000
commit554b3dc27cef6db59f8a612c1e2e3c653f70e392 (patch)
tree2f238e8a8225b27e61bb11ffcdef9acf4920b246 /dev-python/argcomplete
parentaafdd1dcd9a66da0b1bcdfadbca62add48751897 (diff)
gentoo auto-resync : 13:11:2023 - 16:26:20
Diffstat (limited to 'dev-python/argcomplete')
-rw-r--r--dev-python/argcomplete/Manifest3
-rw-r--r--dev-python/argcomplete/argcomplete-3.1.6.ebuild43
-rw-r--r--dev-python/argcomplete/files/argcomplete-3.1.6-timeout.patch24
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/argcomplete/Manifest b/dev-python/argcomplete/Manifest
index e7983ae33709..125edd748c5d 100644
--- a/dev-python/argcomplete/Manifest
+++ b/dev-python/argcomplete/Manifest
@@ -1,5 +1,8 @@
+AUX argcomplete-3.1.6-timeout.patch 1135 BLAKE2B f7092622acfaa4932ea9b85889f6f8767114d5f697039bee992e367e99021018e94408f4ad8d2e1421e22dfe19d764c081021a6fb78264d717843ee71a4988d4 SHA512 b56b8a24e83c9560e9a05d540b075c8274a57432a7a8f3f0d491a0a6ce7e2ac2eae54f79886d48f955fcf6fad5d074202c7ec4f3870569957be51782e1fd23ba
DIST argcomplete-3.1.2.tar.gz 89541 BLAKE2B ca00006d423244096bc2589b26a06826a4ba5541ab73176425a022a35635df3d575a9d6afe99579d7978e20d6b990f0338af6d4525337b135b27084df6352610 SHA512 661b48548e83e2e7a056f8f1151a81eee72c922951e5d3b7194fa0a08ff77c51eb5043237b9f460e5cb56751d9d159a0b43173b951e5f24094b53fd345cb8e85
DIST argcomplete-3.1.4.tar.gz 79529 BLAKE2B 6b2291ab5d8608de6acf760ec00e3ca7edcf2118a09145eb84faa0805e16fe71165513ce9eec875664191869b279bca0e0a8fae540040a5a6b1c9d178e4272b9 SHA512 d5108273fb570ec42667acefd1cf397e2fbedb3d4fbc31bb2b3206cdbb3275fde88b4d40e9dc65045b6a94334e6b5b9136054c6291edc21dcd0542f1369fe4b1
+DIST argcomplete-3.1.6.tar.gz 79685 BLAKE2B df21d5a68a173a3c09b76d866adf949910ad775eb6c7d09d797308e87c128a6eebe173d89fc95aaa42bb87bf08e9c84aa217e8844c9fab5c680c83e07d0c7854 SHA512 7d625dfc49253281f692254a23e7fc4af155b97a7df55a0b33eba9655281702396a1119269cf80b5650885e00d75886fbdcbd85312e7ccac6d940edd6189d50e
EBUILD argcomplete-3.1.2.ebuild 890 BLAKE2B 0193902a301a89fc257d46f4ffe8d91f7b6911e454614a8eebbd466d042cd1f53a02a3ee49ced51791ef62cdcb4bbbe06b7d796cb11c72a17367b94abd1031b9 SHA512 1608543cf0c6601e48cc3f4b4c1ba4c710a80fb596b084ae281acd00022c4a8ccaebc42fe19ad3d1f497499a0206b98a3b58e4c56475f37f22661db458bcadb1
EBUILD argcomplete-3.1.4.ebuild 898 BLAKE2B 6d37c1853154a218c9416510ca92d966811ebc5d798f78043ab24aa77be102afad5995a162a36cc96064fae0b545d5cc76c33dc21fa9982406cd2889de091e19 SHA512 1bbe32beb1703cabe5d15fe963d4fbda79d877fb7677b144d799b83c74a9a172964c00ab5fada7eb11b1a7b714e5f5cb15de186bbd70461a422fb31a0f555fc6
+EBUILD argcomplete-3.1.6.ebuild 1054 BLAKE2B a0a67c2a3e8a8440eca5514d912376b345f46a4e2c0a261c1f2a04f1999c0f6ee773f8828f73af26055b755ebea4dd03624f25a9f4151fb179ec577734db7d00 SHA512 74c9edb59e5f919f6cb97edcd13a95a171656b2aeb2369a85b54aa5ee6f6a3de1988bee2584e2c016fce505e9980b315d37f26e42ff3a329c376efef7b05a368
MISC metadata.xml 411 BLAKE2B 963cfdba9183fde9e97c534345164d26be569d841dcc6fd274601b18d5de2ae97fa837b0acfdc59616c5d19cc54ea368547ffd901f90239cdfb5ba08e8721607 SHA512 22db237979be34053ad7201f599d576a7756b71e6b75c40c2808d47f276cce6d3594ae46dcaec5aa5adab9e9e24e11d47bb9044a8b1a146163d66687965cf5b7
diff --git a/dev-python/argcomplete/argcomplete-3.1.6.ebuild b/dev-python/argcomplete/argcomplete-3.1.6.ebuild
new file mode 100644
index 000000000000..691d9d9b7d84
--- /dev/null
+++ b/dev-python/argcomplete/argcomplete-3.1.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Bash tab completion for argparse"
+HOMEPAGE="
+ https://github.com/kislyuk/argcomplete/
+ https://pypi.org/project/argcomplete/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# pip is called as an external tool
+BDEPEND="
+ test? (
+ app-shells/fish
+ app-shells/tcsh
+ app-shells/zsh
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pip-19
+ )
+"
+
+PATCHES=(
+ # increase test timeouts -- this is particularly necessary
+ # for entry point tests because they read metadata of all installed
+ # packages which can take real long on systems with lots of packages
+ "${FILESDIR}/argcomplete-3.1.6-timeout.patch"
+)
+
+python_test() {
+ "${EPYTHON}" test/test.py -v || die
+}
diff --git a/dev-python/argcomplete/files/argcomplete-3.1.6-timeout.patch b/dev-python/argcomplete/files/argcomplete-3.1.6-timeout.patch
new file mode 100644
index 000000000000..d8348818164d
--- /dev/null
+++ b/dev-python/argcomplete/files/argcomplete-3.1.6-timeout.patch
@@ -0,0 +1,24 @@
+diff --git a/test/test.py b/test/test.py
+index c89912a..eedfe36 100755
+--- a/test/test.py
++++ b/test/test.py
+@@ -1359,7 +1359,7 @@ class TestBashGlobal(TestBash):
+ if sys.platform == "darwin":
+ # Work around https://stackoverflow.com/questions/24257803
+ command += ' --install-option="--prefix="'
+- install_output = self.sh.run_command(command)
++ install_output = self.sh.run_command(command, timeout=300)
+ self.assertEqual(self.sh.run_command("echo $?"), "0\r\n", install_output)
+ command = "test-module"
+ if package:
+@@ -1395,8 +1395,8 @@ class Shell:
+ def run_command(self, command):
+ try:
+ self.child.sendline(r"echo -n \#\#\#; {0}; echo -n \#\#\#".format(command))
+- self.child.expect_exact("###", timeout=5)
+- self.child.expect_exact("###", timeout=5)
++ self.child.expect_exact("###", timeout=30)
++ self.child.expect_exact("###", timeout=30)
+ return self.child.before
+ finally:
+ # Send Ctrl+C in case we get stuck.