summaryrefslogtreecommitdiff
path: root/dev-python/argcomplete/argcomplete-1.11.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/argcomplete/argcomplete-1.11.1-r1.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/argcomplete/argcomplete-1.11.1-r1.ebuild')
-rw-r--r--dev-python/argcomplete/argcomplete-1.11.1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/argcomplete/argcomplete-1.11.1-r1.ebuild b/dev-python/argcomplete/argcomplete-1.11.1-r1.ebuild
new file mode 100644
index 000000000000..a05a6d23449c
--- /dev/null
+++ b/dev-python/argcomplete/argcomplete-1.11.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Bash tab completion for argparse"
+HOMEPAGE="https://pypi.org/project/argcomplete/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ <dev-python/importlib_metadata-2[${PYTHON_USEDEP}]
+ ' -2 python3_{5,6,7} pypy3)"
+# pip is called as an external tool
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-shells/fish
+ app-shells/tcsh
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pip-19
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/argcomplete-1.11.1-fish-xpass.patch
+)
+
+python_test() {
+ "${EPYTHON}" test/test.py -v || die
+}