summaryrefslogtreecommitdiff
path: root/dev-python/apptools/apptools-4.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/apptools/apptools-4.2.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/apptools/apptools-4.2.1.ebuild')
-rw-r--r--dev-python/apptools/apptools-4.2.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/apptools/apptools-4.2.1.ebuild b/dev-python/apptools/apptools-4.2.1.ebuild
new file mode 100644
index 000000000000..dfa685967dc9
--- /dev/null
+++ b/dev-python/apptools/apptools-4.2.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Application tools"
+HOMEPAGE="http://docs.enthought.com/apptools/
+ https://github.com/enthought/apptools
+ https://pypi.org/project/apptools/"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/traits-4[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ >=dev-python/pyface-4[${PYTHON_USEDEP}]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ sci-visualization/mayavi[${PYTHON_USEDEP}]
+ dev-python/traits[${PYTHON_USEDEP}]
+ dev-python/traitsui[${PYTHON_USEDEP}]
+ )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # Ignore test file that imports a long deprecated module of traits
+ VIRTUALX_COMMAND="nosetests -I test_state_pickler.py" virtualmake
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}