summaryrefslogtreecommitdiff
path: root/dev-python/apprise
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-04 11:43:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-04 11:43:04 +0000
commit56a597689e7509193b0924a635d2022f21b1a3e4 (patch)
tree476358a5cea634edc1fb0504f6ec03b282cfb83e /dev-python/apprise
parent57e2174dcd454b41778b7b437f88d0a9f1a6e428 (diff)
gentoo auto-resync : 04:03:2024 - 11:43:04
Diffstat (limited to 'dev-python/apprise')
-rw-r--r--dev-python/apprise/Manifest2
-rw-r--r--dev-python/apprise/apprise-1.7.3.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/apprise/Manifest b/dev-python/apprise/Manifest
index 77f0c755c7a0..a8d0997911ba 100644
--- a/dev-python/apprise/Manifest
+++ b/dev-python/apprise/Manifest
@@ -1,3 +1,5 @@
DIST apprise-1.7.2.tar.gz 1638384 BLAKE2B 8fecb4d08e7e7c3aad24c1f8ac7aaec382aa934d46d5ab7cfd196949c9b7aa9ab2242a7626bddd336932ec12f17cdd966fde293f544e695468cfd810f5e6f5ba SHA512 897d4d253fcc2cfbb3fe2f1d0e9ecbe3a2a1bca65cb2c7d9595410e9c12adc6f5696216365fe583ebc457042db2d7e8a3c6153272865fc996e87342480536a0d
+DIST apprise-1.7.3.tar.gz 1644531 BLAKE2B ea825be56ab037df25b46515e1c2a8dd6da0b202cd117fffd6138bbda183d83ef0586df90198a47de9030bb2e7b2f7c27eea24b30b5df04eee6d557a7f61a910 SHA512 1f5dad1f9b4c89c40a28a889ff03fcae104101678e3fe80063333be8508d17b5cea45dcc8af8fcafea36e5e6455f42659b7ff92be3cb0e4545468ab30a49460c
EBUILD apprise-1.7.2.ebuild 895 BLAKE2B c00ba1868a8bf8f8cedffbf3ff816b35ca67476e955b7083571a06b690012e8a999d74b5518d83885fa5d2b2937100a2370cff66530e760cfb9818aed463ef49 SHA512 8604514dcf11353158f08e2ad60191b0cc5eb52e7124c9f8e2a967fc4c284ca5f7b73b56b4d6a6d4bdeb02ac197b10116bd0ecdf24ea2152800476399a3ddfe8
+EBUILD apprise-1.7.3.ebuild 895 BLAKE2B c00ba1868a8bf8f8cedffbf3ff816b35ca67476e955b7083571a06b690012e8a999d74b5518d83885fa5d2b2937100a2370cff66530e760cfb9818aed463ef49 SHA512 8604514dcf11353158f08e2ad60191b0cc5eb52e7124c9f8e2a967fc4c284ca5f7b73b56b4d6a6d4bdeb02ac197b10116bd0ecdf24ea2152800476399a3ddfe8
MISC metadata.xml 660 BLAKE2B e5d3535632acf00f228e96b2deca73aca518faf9f9e3ec032e13fdea4480e3f83791b3846e456ae47a917a3462c47882358c3ea1c69d20b6332a6ade65340211 SHA512 4c69871bdd771b7cc1af57e018ed1cc1f2194bdf2f7c1e750433911cf75e45f8fa4aa82df71255ce0a1c949db9d220ed614d5932ccf1ff5e78976bec482751a6
diff --git a/dev-python/apprise/apprise-1.7.3.ebuild b/dev-python/apprise/apprise-1.7.3.ebuild
new file mode 100644
index 000000000000..a85837c32c40
--- /dev/null
+++ b/dev-python/apprise/apprise-1.7.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Push Notifications that work with just about every platform"
+HOMEPAGE="
+ https://pypi.org/project/apprise/
+ https://github.com/caronc/apprise/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+IUSE="+dbus mqtt"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ mqtt? ( dev-python/paho-mqtt[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest