summaryrefslogtreecommitdiff
path: root/dev-python/apispec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-09 06:41:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-09 06:41:15 +0000
commitd94fef9a5708b8e64f363f4a71f0b56caef5efe4 (patch)
treeb8041134209c7d8f47560e719b584508ea78180f /dev-python/apispec
parent9991465b0b90d77b2a8a2ae833b6ecd99e6b5101 (diff)
gentoo auto-resync : 09:01:2025 - 06:41:15
Diffstat (limited to 'dev-python/apispec')
-rw-r--r--dev-python/apispec/Manifest2
-rw-r--r--dev-python/apispec/apispec-6.8.1.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index f2bef730e897..5fb3054669d9 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1,5 +1,7 @@
DIST apispec-6.7.1.tar.gz 76714 BLAKE2B ced24f5d455d02a64bbcd098d892bf5f37275eb6cc3ea445b97f89b8e21d0446ae069e1086cdd9c833135931fa3ddf0694eddf10fbbbd81986a59c79f4faf42c SHA512 97a0800f95301b249c57b05560ef45912462c3754f1923530bdfbbbd5e6968f2b1a8174470a5fdb06368d8541a6ef2c76e4964e98cfb47eea0715e1e7abaac7f
DIST apispec-6.8.0.tar.gz 76919 BLAKE2B c97f9a87175755c517a22ebbe66c1fb058b89f370a89f09af1007664519d95cf5938e1b699062f9b7f643bc3263a2055487996f759e0e64e2e2038d36e552525 SHA512 ad8b155dcc373f2423153a4b17d3b446a188e8835ea971496818a93bea098b641a3663dc75b6cd8b92a92de607ddc64fb9b13ad10356e6eeb05e4ff9918e9ecf
+DIST apispec-6.8.1.tar.gz 77050 BLAKE2B 394714c23721a18cf205c9f705bebbfa34d508d333e34cd89bab7e4fbd0f61d1427f55d94425135dbbd9a4b6eff1b313bea156ca29eccbc21865787e296ada6c SHA512 db6e92ce765ae8a7cb0dafe2b6bdcf47ff4849f7d11b344526640d3536ff5251b644bb49f9385dafea339eeb59072fc08094b309f4092080fcf9ec582071fc9d
EBUILD apispec-6.7.1.ebuild 1017 BLAKE2B 17411418f95b290ad4ff867527a2f23928256d9e4a34837c96aa57a55a9328340649b7c2ed1bcdb1b7775aa243746b40863303c6bbed73cecf577791ed63c365 SHA512 ab1bd961a10ca1163c895f1c80571c3650d027a0e094788e807641c32dfb59fa6432e0a8042e04a8c1717dd3a4bcac8253ec8273a0d635f0f3fce9fdcd355302
EBUILD apispec-6.8.0.ebuild 1017 BLAKE2B 17411418f95b290ad4ff867527a2f23928256d9e4a34837c96aa57a55a9328340649b7c2ed1bcdb1b7775aa243746b40863303c6bbed73cecf577791ed63c365 SHA512 ab1bd961a10ca1163c895f1c80571c3650d027a0e094788e807641c32dfb59fa6432e0a8042e04a8c1717dd3a4bcac8253ec8273a0d635f0f3fce9fdcd355302
+EBUILD apispec-6.8.1.ebuild 1017 BLAKE2B e67a0fce87f9ac0007449ae6d027b624e3b3d6c8aec5bc335c117430c43fee18c8f97be6655415d10cc2a9b3f640a6615358af85acff77d63e4bc9e13590c9e8 SHA512 c6bc2d531ff4b0d92efffeed115cb42b6a4f622e2e591c0c2328399f484437a8578f01908a2b2893eb6ef79458110990ff6627d4a9b373aba273a7496e9b4192
MISC metadata.xml 504 BLAKE2B d55ae521520ba60a139e83f23aacbb3df76c4c120a54f1b65b185018647c1f363bc88f354abc1810b7a9d9f3cfa264e0303d46cd23b8091dbb365bd84cc04815 SHA512 e0297e941c3c544cbb14044f02451c26cfdec81b2bd49cf225dc9f32d1ccb207e630d838d8928d28ccb35a3cf01493a87ceb2633cc5ede36b62a6d81f164ea32
diff --git a/dev-python/apispec/apispec-6.8.1.ebuild b/dev-python/apispec/apispec-6.8.1.ebuild
new file mode 100644
index 000000000000..337253ee2b06
--- /dev/null
+++ b/dev-python/apispec/apispec-6.8.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pluggable API specification generator"
+HOMEPAGE="
+ https://github.com/marshmallow-code/apispec/
+ https://pypi.org/project/apispec/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.18.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-rtd-theme
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}