summaryrefslogtreecommitdiff
path: root/dev-python/apispec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-11 01:05:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-11 01:05:34 +0000
commit7ece7f3d3bcd0184dd8dfd6653464da80184963c (patch)
tree11ae8def15c0148aaf70c9bcfb86da05c82de6a1 /dev-python/apispec
parent6a4408b9bbd9fe61dc0966f587db94081fa5f52b (diff)
gentoo auto-resync : 11:01:2024 - 01:05:34
Diffstat (limited to 'dev-python/apispec')
-rw-r--r--dev-python/apispec/Manifest2
-rw-r--r--dev-python/apispec/apispec-6.4.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index 069144870cd6..707da1cd8a49 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1,3 +1,5 @@
DIST apispec-6.3.1.tar.gz 77634 BLAKE2B e98a4d14f12248b27af1b5b12b642e416af7cf4f36386406ad0784e7d8930a71391de2ed627d6093e907048bb3a145abf06fca1b5b3e0595346d45fd6be6775f SHA512 977d9f890728a336b8e604f5ab7feb850f0f65e9fb64aa10cb2697d27bbd89137c6b08719b6cc422efc11c80cea6f6646709c33d340b0a63345fe93f2aa92902
+DIST apispec-6.4.0.tar.gz 79114 BLAKE2B 998b153a3d80c45247148210a929a0713d930560a4219dc0da0791e02480ff2a99a74d0b8bc2c170534f7d9e4e05a5fa231fa1d0eaf9359191e7ea6f37e5caf3 SHA512 2b9ceb99945c2e40e00af9f1626d0bd45cdb853fea1b75c58ef312b42b10d521405138c3bc788a33bf38eb31fc9220ed8e9a23c6a3c8980fc5549688d999dcdf
EBUILD apispec-6.3.1.ebuild 1023 BLAKE2B 9b47968855adc0f7e8ad46580a8cea7f6804a31cd038b6e62a911c17fd927b79cf677d615789768cff502ccb083445c174f1d1958c8a1d645dd98961d349b381 SHA512 d900933e86c767bc667d7f97e2382548374715f2fddd43648969447acdb41b5b4680d0995fe977b49f9881139e4bd017d15c6f07c820ff9073be2652b40e8958
+EBUILD apispec-6.4.0.ebuild 1023 BLAKE2B 3cd548efcc61ec2854b9f02273eac1843cdc759f47ee7fe861b39930324ccafb650d58c2b91cacb851c1c68a99ed16fe76dacd9986be353b753ba55eb460d4a6 SHA512 e3198e1c32e7259bb6cd99eb3fc7b5988dfc03b2b8cec246288b943db86942769d31e4578614162c79795b536894903fe6a8fcc8c9057be137c4b49de1012a9c
MISC metadata.xml 504 BLAKE2B d55ae521520ba60a139e83f23aacbb3df76c4c120a54f1b65b185018647c1f363bc88f354abc1810b7a9d9f3cfa264e0303d46cd23b8091dbb365bd84cc04815 SHA512 e0297e941c3c544cbb14044f02451c26cfdec81b2bd49cf225dc9f32d1ccb207e630d838d8928d28ccb35a3cf01493a87ceb2633cc5ede36b62a6d81f164ea32
diff --git a/dev-python/apispec/apispec-6.4.0.ebuild b/dev-python/apispec/apispec-6.4.0.ebuild
new file mode 100644
index 000000000000..df8ddd83f780
--- /dev/null
+++ b/dev-python/apispec/apispec-6.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pluggable API specification generator"
+HOMEPAGE="
+ https://github.com/marshmallow-code/apispec/
+ https://pypi.org/project/apispec/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.18.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-rtd-theme
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}