summaryrefslogtreecommitdiff
path: root/dev-python/apispec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-15 13:50:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-15 13:50:34 +0100
commit7b0230b9f0a5cbd2779e7b25d57df8c33b6d0a88 (patch)
treea6a3e9599958059e99a9753cffba162ceb14b9b9 /dev-python/apispec
parentafc11599d81c08d253ed16222206ccd408d6c3cf (diff)
gentoo auto-resync : 15:10:2022 - 13:50:34
Diffstat (limited to 'dev-python/apispec')
-rw-r--r--dev-python/apispec/Manifest2
-rw-r--r--dev-python/apispec/apispec-6.0.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index e8e65d5310a0..a16052b17453 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1,3 +1,5 @@
DIST apispec-5.2.2.gh.tar.gz 71563 BLAKE2B 205c796ccee03000626538147d6cb26a72242ba8ffd6df47b6a7bdb82f0e2ee1d5421cb7da045fc177297acb838e7351ae996225a43c3c7a57a0a0d72e098bb1 SHA512 16c6229619853671403e81edaa50ce87c2575cdb6c606502e08c086aa33b25db0cef0cd455c2c74a55138eaf95667f7ffe9ac8045cbeb415df4b623878a8831c
+DIST apispec-6.0.0.gh.tar.gz 72200 BLAKE2B c65278602c7f05074bf6e4e36a5e7aeaf0eabcc281c387448666f6958eef95a4f4f297055f58eb580169249cc90c1643bcdef0f9281792e4840d719cc921c9f3 SHA512 4c4c34554241fba67d0aad41aa81e5c6e97ee42003da503afa223ff5fbf0046a8b5f3dc3835fe9ae1dc03181f4be5fabae1a7d80871c0a061602d2593315b2db
EBUILD apispec-5.2.2.ebuild 1015 BLAKE2B ddd3b89deb36da9e1acab8c1d0be6cb40562442c1d792fd7247309a36a714b7f97e9d389830a4ca27e6f018697ebac4b49bdc632c6d19ce4f8448c7476efa792 SHA512 ea3e878b515abe0405c5b0dd31f360909a6b860ca7d01d2d9c7566e5a5687929aaddd709a17c8867a14e0f0799115b0e5519a2ca98d48c6463501e7393e29a8c
+EBUILD apispec-6.0.0.ebuild 1062 BLAKE2B d8a000dd2659779b0329077c7881935323cdeb650340a3f6954b4278914d4ba9d73dad971e5566b3649351ad7d4dd7ce2043eb5f665001c3eb35d469b4a4580b SHA512 92d8b2f6915c644045c77cd267b088b69b8e0a0215fcedbc122325f0303ecb3ec25cdc848f310887b33eb937775a553b5daaecd5de5fbc246a47ad8039e18cd6
MISC metadata.xml 504 BLAKE2B d55ae521520ba60a139e83f23aacbb3df76c4c120a54f1b65b185018647c1f363bc88f354abc1810b7a9d9f3cfa264e0303d46cd23b8091dbb365bd84cc04815 SHA512 e0297e941c3c544cbb14044f02451c26cfdec81b2bd49cf225dc9f32d1ccb207e630d838d8928d28ccb35a3cf01493a87ceb2633cc5ede36b62a6d81f164ea32
diff --git a/dev-python/apispec/apispec-6.0.0.ebuild b/dev-python/apispec/apispec-6.0.0.ebuild
new file mode 100644
index 000000000000..b82fa25e0226
--- /dev/null
+++ b/dev-python/apispec/apispec-6.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pluggable API specification generator"
+HOMEPAGE="
+ https://github.com/marshmallow-code/apispec/
+ https://pypi.org/project/apispec/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/apispec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.18.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx_rtd_theme
+
+EPYTEST_DESELECT=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+)