summaryrefslogtreecommitdiff
path: root/dev-python/apispec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-04 07:37:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-04 07:37:02 +0000
commit5ae7efc9abae6bb8f8fac438298427769a91f5ad (patch)
treedc25abd0d9e2475f76b5060721ab492d2958a45f /dev-python/apispec
parent2e6b794bf4361b8ae32bb6945e84696c2e1d94ba (diff)
gentoo auto-resync : 04:03:2023 - 07:37:01
Diffstat (limited to 'dev-python/apispec')
-rw-r--r--dev-python/apispec/Manifest2
-rw-r--r--dev-python/apispec/apispec-6.1.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index 75fcaa9dcd03..6af2ad3d19bf 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1,3 +1,5 @@
DIST apispec-6.0.2.gh.tar.gz 72472 BLAKE2B 0ff39ad92648cd63487f8901dc918fc1c642ce677ef73d5a7c849cdafbf7c81ac3ec51224575cd83c060930c1b2ef0ebfb3e94e1fb30f040e4dc4aa2bd221936 SHA512 aa5e2cc41d5b3c4555da929819135df30192e6f6ff08518d62674495f0d28c14e51a0aa111b289e5f9d7205f821c1fd4e28b914899ea3e15b3e20f6052258117
+DIST apispec-6.1.0.gh.tar.gz 72570 BLAKE2B 524573d188c487c57bed25f735888623d3abb848a949920bfa7ef8737b33d5fa29670d90af47eedb8b6202ddd553d04c2809285151555159c81203989fe23a2c SHA512 95d24491992572304b5c5adbb2a50668d55cb60585e32c85f718f2c211eb15c35082146fd6c88b7d3d574b4fef8f49fdd3cfe714f15d80aa657f3b48f38a40ed
EBUILD apispec-6.0.2.ebuild 1108 BLAKE2B 06db107a509f97325fcd982824ff0f5b1de72cc48cc075e0175d6144c4a34c087106ec52bbcca0a790603c2fefa2797dfcc562618283787afa37c4310f633383 SHA512 6f4133bd06b918d03c4bd45854cf5c4b8d8a278d1dde2b7dac8a59eb88dff3dd61428bcd69b67fd9587176af288ffb4d1486191c3913c3a72108731bab0b743e
+EBUILD apispec-6.1.0.ebuild 1108 BLAKE2B 06db107a509f97325fcd982824ff0f5b1de72cc48cc075e0175d6144c4a34c087106ec52bbcca0a790603c2fefa2797dfcc562618283787afa37c4310f633383 SHA512 6f4133bd06b918d03c4bd45854cf5c4b8d8a278d1dde2b7dac8a59eb88dff3dd61428bcd69b67fd9587176af288ffb4d1486191c3913c3a72108731bab0b743e
MISC metadata.xml 504 BLAKE2B d55ae521520ba60a139e83f23aacbb3df76c4c120a54f1b65b185018647c1f363bc88f354abc1810b7a9d9f3cfa264e0303d46cd23b8091dbb365bd84cc04815 SHA512 e0297e941c3c544cbb14044f02451c26cfdec81b2bd49cf225dc9f32d1ccb207e630d838d8928d28ccb35a3cf01493a87ceb2633cc5ede36b62a6d81f164ea32
diff --git a/dev-python/apispec/apispec-6.1.0.ebuild b/dev-python/apispec/apispec-6.1.0.ebuild
new file mode 100644
index 000000000000..a4536d135d69
--- /dev/null
+++ b/dev-python/apispec/apispec-6.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pluggable API specification generator"
+HOMEPAGE="
+ https://github.com/marshmallow-code/apispec/
+ https://pypi.org/project/apispec/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/apispec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.18.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-rtd-theme
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}