summaryrefslogtreecommitdiff
path: root/dev-python/apispec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-11 15:30:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-11 15:30:13 +0000
commit469b5d8f31adfd054c5c493fc3df2f9c89c9fa00 (patch)
treef51c77713647680335a341aeb6c5a7fa019a000b /dev-python/apispec
parent7d6f532c36268a2a8f53fa33c8e547c59702faa6 (diff)
gentoo auto-resync : 11:11:2022 - 15:30:13
Diffstat (limited to 'dev-python/apispec')
-rw-r--r--dev-python/apispec/Manifest2
-rw-r--r--dev-python/apispec/apispec-6.0.2.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index f40a76e8464f..94b23df23b47 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1,5 +1,7 @@
DIST apispec-6.0.0.gh.tar.gz 72200 BLAKE2B c65278602c7f05074bf6e4e36a5e7aeaf0eabcc281c387448666f6958eef95a4f4f297055f58eb580169249cc90c1643bcdef0f9281792e4840d719cc921c9f3 SHA512 4c4c34554241fba67d0aad41aa81e5c6e97ee42003da503afa223ff5fbf0046a8b5f3dc3835fe9ae1dc03181f4be5fabae1a7d80871c0a061602d2593315b2db
DIST apispec-6.0.1.gh.tar.gz 72293 BLAKE2B cc5bc094965bc8ce7b9f4de6292aeaaf9a873c12841230f53c32e0e732fbced0e8d02461bef8cf3bde5d715c63edd697d6c3429f4a27e767b31a1ba101dc5aaa SHA512 fabe14511a1dd598101977bcab70e5bdb1338f219f348f9584062d0c4c80de8adc1eb7f5e202a6a9d1e3fa11d775de2871f238585f6b6471bebdb3fe47bf0dc0
+DIST apispec-6.0.2.gh.tar.gz 72472 BLAKE2B 0ff39ad92648cd63487f8901dc918fc1c642ce677ef73d5a7c849cdafbf7c81ac3ec51224575cd83c060930c1b2ef0ebfb3e94e1fb30f040e4dc4aa2bd221936 SHA512 aa5e2cc41d5b3c4555da929819135df30192e6f6ff08518d62674495f0d28c14e51a0aa111b289e5f9d7205f821c1fd4e28b914899ea3e15b3e20f6052258117
EBUILD apispec-6.0.0.ebuild 1062 BLAKE2B d8a000dd2659779b0329077c7881935323cdeb650340a3f6954b4278914d4ba9d73dad971e5566b3649351ad7d4dd7ce2043eb5f665001c3eb35d469b4a4580b SHA512 92d8b2f6915c644045c77cd267b088b69b8e0a0215fcedbc122325f0303ecb3ec25cdc848f310887b33eb937775a553b5daaecd5de5fbc246a47ad8039e18cd6
EBUILD apispec-6.0.1.ebuild 1026 BLAKE2B f9a518721fb33bc13a9072fd81a2deeaf514429dc32021b2536c1495ada4030596e0084567ae85ae2b0111603935b58b7d471f83fc56e224dbdab35a22c38bd4 SHA512 88fea9e94c5e4b8da8f02ff791a7fc4c86053451922a41f72d500fe647f96466c4e1a54b74498ec19bee9ca486b758b60cfdeb246f3c905ce8d1b1b69ba7c362
+EBUILD apispec-6.0.2.ebuild 1108 BLAKE2B 5c0ac8052fdc2304a6fe0798c055452c839828d993534cf5105c73c562878bb9f6714e834b9f54654f58972fd17bf1ef0ec6bc8dd48e8cc00551501e2e3a7286 SHA512 c53047df7bdf94cb35b30bfb033a1baecbbfcb9f082fddde1b3231edff29bdfd700435b680e7e995a32ab5c059d92afe59e1ab1fcec2a0370fdf0da66eea6ac6
MISC metadata.xml 504 BLAKE2B d55ae521520ba60a139e83f23aacbb3df76c4c120a54f1b65b185018647c1f363bc88f354abc1810b7a9d9f3cfa264e0303d46cd23b8091dbb365bd84cc04815 SHA512 e0297e941c3c544cbb14044f02451c26cfdec81b2bd49cf225dc9f32d1ccb207e630d838d8928d28ccb35a3cf01493a87ceb2633cc5ede36b62a6d81f164ea32
diff --git a/dev-python/apispec/apispec-6.0.2.ebuild b/dev-python/apispec/apispec-6.0.2.ebuild
new file mode 100644
index 000000000000..82bb02125050
--- /dev/null
+++ b/dev-python/apispec/apispec-6.0.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pluggable API specification generator"
+HOMEPAGE="
+ https://github.com/marshmallow-code/apispec/
+ https://pypi.org/project/apispec/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/apispec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.18.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx_rtd_theme
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}