summaryrefslogtreecommitdiff
path: root/dev-python/apipkg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-19 23:10:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-19 23:10:29 +0100
commit318828e81fe6707ce5a64e6a59a76d4c0ca709f8 (patch)
treecc4b7818f7960cb193ad2bf7f7defe71adb3ee47 /dev-python/apipkg
parent590c04803f88a968b4a750c0f420eb314e1fe968 (diff)
gentoo auto-resync : 19:09:2023 - 23:10:29
Diffstat (limited to 'dev-python/apipkg')
-rw-r--r--dev-python/apipkg/Manifest2
-rw-r--r--dev-python/apipkg/apipkg-3.0.2.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/apipkg/Manifest b/dev-python/apipkg/Manifest
index 5bd3e9e7c4c7..a28d618c087d 100644
--- a/dev-python/apipkg/Manifest
+++ b/dev-python/apipkg/Manifest
@@ -1,3 +1,5 @@
DIST apipkg-3.0.1.gh.tar.gz 14026 BLAKE2B da16bea557cf870c96d44a383232344d10cfbb682c483468e20755dd378c64e64d72b379901eb59ed0df590b5c3b577c882beb882377f7d759b181cf1b672b50 SHA512 89251f02a49b5191879bcf6e35c6a8755d6b29f1ca1c6061eab004385b11433ec86e2968ab23994c6a74515d6a673e445b3bcf8cbdd21b2ec644fcef0d19b419
+DIST apipkg-3.0.2.gh.tar.gz 14018 BLAKE2B 2c7734db09a9718353ba1e99fd0bb4320b9e4e2a9d509d7d93c65dbb6477be6cd71149023c3b8de3e4d5226d337d44065710fe9358ccfcc29d26c968ca84a778 SHA512 57bd819869d441bc00bcba36bb4308a98f9e36114ddfb44dbb9c3123aafb5972fbbce4d7cab8f0f82d789837679d5b3c62fbd2d03d870c53095782798d0c59b6
EBUILD apipkg-3.0.1.ebuild 700 BLAKE2B 9f466fe2d6a9768795d55eddee635c3dd8040061156d2c3f82ecd5b1fa87893e86e00076a5b3d690a02179baa4b4649c235fb36e6246308a85e9316d0880bfa6 SHA512 1119699fba32677602109f4519627cd8f8b33c9b2a8e5c13be5a1ea79da72a0ae213f8090760f59dede9da7f1520fb41caf03030ec252ef48dddd573daf8c63c
+EBUILD apipkg-3.0.2.ebuild 708 BLAKE2B d0284e48934b5aca1c5db2aed73c2ae35b2b5f18daaec01406c9f3a386c4fb98b193d9ee6c000adce7c6bcf0aa2e9d372d21239454e31a16a05ffe35a7d7b950 SHA512 b9a53ca6fadfa4ef8534ecb6b900afc6d31f6b04f7a4a2d4fc2678fdb8caa0fa3cd991506a291c1ac06ec89c8c30a999619e567f79d91c0326d03df258c5dea3
MISC metadata.xml 391 BLAKE2B 3dbeb8dab14b48bbbeae054533b14b87196da9b34fb6a09f39354a7d9b97652858bb8011c88c2d268b6402a1a6565aff53017220ef84a08694111d3bcf413a52 SHA512 bdec41dba3cba6e644a542e44e65a294e77b6f84f35fac11e84e3c55fbdf19a3b4381caae604c06f92ca5d8cdf1a36519a9f8aa841041b1fb6f16675365da640
diff --git a/dev-python/apipkg/apipkg-3.0.2.ebuild b/dev-python/apipkg/apipkg-3.0.2.ebuild
new file mode 100644
index 000000000000..eb4e82049ad9
--- /dev/null
+++ b/dev-python/apipkg/apipkg-3.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/_/}
+DESCRIPTION="Namespace control and lazy-import mechanism"
+HOMEPAGE="
+ https://github.com/pytest-dev/apipkg/
+ https://pypi.org/project/apipkg/
+"
+SRC_URI="
+ https://github.com/pytest-dev/apipkg/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}