summaryrefslogtreecommitdiff
path: root/dev-python/anyio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-28 09:14:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-28 09:14:16 +0100
commitdd543f86f47d3b1796d2190759773c75779ba7ad (patch)
tree1dddd805c490b599a7cab3de2cd91cbf0a5632e6 /dev-python/anyio
parent369ea1911997ca4bdb3c70969256af7bbf275699 (diff)
gentoo auto-resync : 28:05:2023 - 09:14:16
Diffstat (limited to 'dev-python/anyio')
-rw-r--r--dev-python/anyio/Manifest2
-rw-r--r--dev-python/anyio/anyio-3.7.0.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/anyio/Manifest b/dev-python/anyio/Manifest
index 37fe92bb420f..c4bd5e848262 100644
--- a/dev-python/anyio/Manifest
+++ b/dev-python/anyio/Manifest
@@ -1,3 +1,5 @@
DIST anyio-3.6.1.tar.gz 140240 BLAKE2B 391892591bee88df8fd5c099b6670af8e01af0610f7659e2f2e717c2dfd94d6e5212260acf3acca6c8b149cab6781044fb665d579a63b322332bf87767374858 SHA512 99ae55eada2df971405a1592afd980ac964c80a4502465a2016423182409691d0c943280a3a7448efc78036e481614451585238b62ebea924709f0ba888f7604
+DIST anyio-3.7.0.tar.gz 142737 BLAKE2B f27b6c854f8861c760a922542471b5d7714cd54da0fa999a6efc8e394b49e538e7689147834a4076e1970932416fabe820923c2155048d943eee697454771c8f SHA512 0793012dc364d2bb27ebae8a23f275ecd24d444de750fbebcb72e70ca465a3be9c69938543e1a3c686abfff3ed9036974b38e3886fb24a110a9ef307a82d3f0b
EBUILD anyio-3.6.1.ebuild 1261 BLAKE2B 29ce1a3ea48e87c2c8873680b296c80c4312cb6009b8cb1492ce50aff62bf2072ac2962ff6ce909d0493e8f967bcee06f3dce8b1ab9d8651c16cf94ff82f5d83 SHA512 5ac4030d803427c55b3a2545c628076ac27e4cdfbe7f23fef64b53e396618f552101924dcf875949020e605fd2471fc80b67681530e7dc07513bd78c999c406d
+EBUILD anyio-3.7.0.ebuild 1872 BLAKE2B a92c474a22081c668bf1de23ea904983c2502fd95fcf77b279c915c649f8480d7f7047a4af4bbb7223e74c320a9784d51aef219caf58882183b09af04dec857d SHA512 d63fb30c556a6653fd9d171ba01603d87cf6d421073fb5456786a27bb082ef21cf24e7c908fc9fa999e3d00f0479964976ce59ee03543efd92f2b9f71e4a0b46
MISC metadata.xml 1422 BLAKE2B 63acae587e7088e33ee5eb93a2a222899e54a5eb511118794f88e7c5a012d10983eb925427688a0b509b094e30a9cc9acc5f0c1765ea73e569161e0c30722000 SHA512 e0b540d5d739b7673a5a8682477f209f8b3648aad06a1c0610543a2e9dcbeca1cb1e52212d8088a5987a1c3bc3152cc5984ad5b5d0706fcdb5866b22de07b1eb
diff --git a/dev-python/anyio/anyio-3.7.0.ebuild b/dev-python/anyio/anyio-3.7.0.ebuild
new file mode 100644
index 000000000000..3d11a37fec4e
--- /dev/null
+++ b/dev-python/anyio/anyio-3.7.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Compatibility layer for multiple asynchronous event loop implementations"
+HOMEPAGE="
+ https://github.com/agronholm/anyio/
+ https://pypi.org/project/anyio/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+ >=dev-python/idna-2.8[${PYTHON_USEDEP}]
+ >=dev-python/sniffio-1.1[${PYTHON_USEDEP}]
+"
+# On amd64, let's get more test coverage by dragging in uvloop, but let's
+# not bother on other arches where uvloop may not be supported.
+BDEPEND="
+ >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-4.0[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ amd64? (
+ $(python_gen_cond_dep '
+ >=dev-python/uvloop-0.17[${PYTHON_USEDEP}]
+ ' python3_{10..11})
+ )
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme \
+ dev-python/sphinx-autodoc-typehints
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires link-local IPv6 interface
+ tests/test_sockets.py::TestTCPListener::test_bind_link_local
+
+ # trio-0.22?
+ 'tests/test_sockets.py::TestTCPStream::test_connection_refused[trio-multi]'
+ 'tests/test_taskgroups.py::test_exception_group_children[trio]'
+ 'tests/test_taskgroups.py::test_exception_group_host[trio]'
+ 'tests/test_taskgroups.py::test_exception_group_filtering[trio]'
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m 'not network'
+}