summaryrefslogtreecommitdiff
path: root/dev-python/anyio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/anyio
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/anyio')
-rw-r--r--dev-python/anyio/Manifest3
-rw-r--r--dev-python/anyio/anyio-3.1.0.ebuild54
-rw-r--r--dev-python/anyio/metadata.xml34
3 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/anyio/Manifest b/dev-python/anyio/Manifest
new file mode 100644
index 000000000000..a80ffc318926
--- /dev/null
+++ b/dev-python/anyio/Manifest
@@ -0,0 +1,3 @@
+DIST anyio-3.1.0.tar.gz 122097 BLAKE2B 4a16a5d231cc5262dd4138f628b9d210180733bda4b9e81ced0c0e0c7f49e1760c8dd22db0a1db3b7a21f3210072f4e1c543e52a7dc716ad3f0415827da48e38 SHA512 120d8e3e24f542c06caedd0a67d16b3fb69c94f5feaebde5262e54f8ffba3f1cf927c82030d65fa2efb3479ee64abd968b6ce67aee767ea33ccef6b0e3fbd358
+EBUILD anyio-3.1.0.ebuild 1413 BLAKE2B 35471e090dad1e7d2a820c2c1d225e211311f673bf8d4a6d1adf5d0221d293fad3813295b17ddac496f603a1e26737b7bd43135361f4c5cfbfd29b48fd479f21 SHA512 dff8ec2ff5c87f0bea1d083fe62685c4580580e17bcedb14b014396a280e2468cd548b44bb492e5b64b09c61c49a4f86f043dcbd7e4a1bddb58b8bfff5b443de
+MISC metadata.xml 1320 BLAKE2B 0687bd9663338d0f39ad5b705f3ba3064ad7a399e31e6b6dfba80124b4ce719bbde82fb39f8b19b4a2fd22a040919163a59bfb57a3db143983d60db78d05811e SHA512 306491b404e5929eb19f61e359741b2961b3e600e3e6190e29215ea571db2d270d469c331956246f3336e05f5379d37d35bbea30931a9bbd8fb79a671d7642ce
diff --git a/dev-python/anyio/anyio-3.1.0.ebuild b/dev-python/anyio/anyio-3.1.0.ebuild
new file mode 100644
index 000000000000..d4d7d1e46906
--- /dev/null
+++ b/dev-python/anyio/anyio-3.1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Compatibility layer for multiple asynchronous event loop implementations"
+HOMEPAGE="
+ https://github.com/agronholm/anyio
+ https://pypi.org/project/anyio/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/idna-2.8[${PYTHON_USEDEP}]
+ >=dev-python/sniffio-1.1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ >=dev-python/uvloop-0.15[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinx-autodoc-typehints
+
+python_prepare_all() {
+ # This will pull in dev-python/trio and a whole bunch of other new things
+ # And trio does not yet have a release compatible with python3.9.
+ rm tests/test_taskgroups.py || die
+ sed -i -e '/trio/d' tests/conftest.py || die
+ sed -i -e 's/test_cancel_scope_in_asyncgen_fixture/_&/' \
+ -e 's/test_autouse_async_fixture/_&/' \
+ -e 's/test_plugin/_&/' \
+ tests/test_pytest_plugin.py || die
+
+ # skip network test
+ sed -i -e 's/test_getaddrinfo/_&/' tests/test_sockets.py || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/anyio/metadata.xml b/dev-python/anyio/metadata.xml
new file mode 100644
index 000000000000..99d53f711918
--- /dev/null
+++ b/dev-python/anyio/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <longdescription lang="en">
+AnyIO is a asynchronous compatibility API that allows applications and libraries written against it to run unmodified on asyncio, curio and trio.
+
+It bridges the following functionality:
+
+Task groups
+Cancellation
+Threads
+Signal handling
+Asynchronous file I/O
+Subprocesses
+Inter-task synchronization and communication (locks, conditions, events, semaphores, object streams)
+High level networking (TCP, UDP and UNIX sockets)
+You can even use it together with native libraries from your selected backend in applications. Doing this in libraries is not advisable however since it limits the usefulness of your library.
+
+AnyIO comes with its own pytest plugin which also supports asynchronous fixtures. It even works with the popular Hypothesis library.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">agronholm/anyio</remote-id>
+ <remote-id type="pypi">anyio</remote-id>
+ <maintainer status="unknown">
+ <email>alex.gronholm@nextday.fi</email>
+ <name>Alex Grönholm</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>