summaryrefslogtreecommitdiff
path: root/dev-python/anyio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-19 17:39:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-19 17:39:35 +0000
commit9aa795a0179b29f7489bd04584bc8d2914da467b (patch)
treee628e5bd3419ed93917cff26165964b8d82064f6 /dev-python/anyio
parentfac3cfaabc3c46bf5cb7a2492197925c7c557b42 (diff)
gentoo auto-resync : 19:02:2024 - 17:39:34
Diffstat (limited to 'dev-python/anyio')
-rw-r--r--dev-python/anyio/Manifest2
-rw-r--r--dev-python/anyio/anyio-4.3.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/anyio/Manifest b/dev-python/anyio/Manifest
index c4b8a4e16508..a2a26ab9529a 100644
--- a/dev-python/anyio/Manifest
+++ b/dev-python/anyio/Manifest
@@ -1,5 +1,7 @@
DIST anyio-3.7.1.tar.gz 142927 BLAKE2B 80a093943fbd23069e9511a83b3eb1e27f2863b11e184709f92cab2dfebc05ea3c291d22be4b1e79d00ae52e10009d5fb2c664730009b40e2b666587538d0ca5 SHA512 067bbffa9e0d6ce339a4999a677c857e839aa3bf5a056d841fec8cbd3be17023c9158df907ff66b9a5437a78158bc9bbb3b9ebe30c57ef98660642bc057d7d10
DIST anyio-4.2.0.tar.gz 158770 BLAKE2B 10ae621872edb27727c8931904c84f41dc18ef0cc4cce1ea18c957d479be24b1a4ffb15d8a9e2b4338663fdbc2a989e5772ba1bd2076f9f0b22f6f5c4feef4bc SHA512 a6f3cbedbfa063a5cf031cd833e6da7a23ee37dbdae8d47ccdfb09c61a73c186267f1a33ba6b4936cac7fb4c970f5488ff1464295e5ffa452952732ac0468d65
+DIST anyio-4.3.0.tar.gz 159642 BLAKE2B 33b300d1da37137d45b311f8424c022d19518c207c39ec6f8bd3e42432cf1457f2d533eadeaa1e21853ed1b25a4f58818fc595e8588489722846f8a8d72262dc SHA512 26ff552a03b24b63c7c99cffcec61e97289eacba3ad2fc7a3c1dde8cfaffd9a8d621b867429901c12d7cef912d3807db134dbeb9c5ba619921160f6d5df4d02f
EBUILD anyio-3.7.1.ebuild 2031 BLAKE2B 92d72a3c4833070582501bd18646c41c8d1a8551adae6dda13ea3fd7de20d199a3e3bcf5d8326d6c998c7ad9bf1d38291b05ad970c2c74b0698b66d9ca9c3c8b SHA512 233f500a7a0e2b2b7c371ee7a2ecbaa3ee5e52d1c557c5d9d94e6098590175a305a45960036a9106a2b56c8ec1cb84ba500221d473224ee30519f47119d7fc94
EBUILD anyio-4.2.0.ebuild 1684 BLAKE2B 82452731d1288270c4d6229f5a8aedf5e930f292ad4df17e145fa4239390dc9172623fa33c464893bc371c74023c7ffe7fc1e6801a4cbd09872ab6c3def463c8 SHA512 478925f2d70e8c5130f75a2650da30b5c8e772a79d25d2dc73d5eafb4d9ad6e8afaa23d94074993d14b1928b0aefd53fc6fc8840363a2ec514142a83f5c9039d
+EBUILD anyio-4.3.0.ebuild 1692 BLAKE2B 4717758a6e86e9ae8ee11ec3d51de1af31e91bcc6a313160026924bbb9be22c973ee2d9084e38dc8a6ed2dd5a6cf6a000860df07d6b0dcdd0ef9dbbd402e46f4 SHA512 c6ef93b1e08b2d662935a6347e6bdba9b553fedf74869b12c278875bee44272b6ecbc168a016e88a3b851d6b0294f17e3ec311fc07a409ba09d00dcf70e7cd9d
MISC metadata.xml 1422 BLAKE2B 63acae587e7088e33ee5eb93a2a222899e54a5eb511118794f88e7c5a012d10983eb925427688a0b509b094e30a9cc9acc5f0c1765ea73e569161e0c30722000 SHA512 e0b540d5d739b7673a5a8682477f209f8b3648aad06a1c0610543a2e9dcbeca1cb1e52212d8088a5987a1c3bc3152cc5984ad5b5d0706fcdb5866b22de07b1eb
diff --git a/dev-python/anyio/anyio-4.3.0.ebuild b/dev-python/anyio/anyio-4.3.0.ebuild
new file mode 100644
index 000000000000..694cd3be7f30
--- /dev/null
+++ b/dev-python/anyio/anyio-4.3.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Compatibility layer for multiple asynchronous event loop implementations"
+HOMEPAGE="
+ https://github.com/agronholm/anyio/
+ https://pypi.org/project/anyio/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/exceptiongroup-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.8[${PYTHON_USEDEP}]
+ >=dev-python/sniffio-1.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+# On amd64, let's get more test coverage by dragging in uvloop, but let's
+# not bother on other arches where uvloop may not be supported.
+BDEPEND="
+ >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-4.0[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.23[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ amd64? (
+ $(python_gen_cond_dep '
+ >=dev-python/uvloop-0.17[${PYTHON_USEDEP}]
+ ' python3_{10..12})
+ )
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ '>=dev-python/sphinx-rtd-theme-1.2.2' \
+ dev-python/sphinxcontrib-jquery \
+ dev-python/sphinx-autodoc-typehints
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires link-local IPv6 interface
+ tests/test_sockets.py::TestTCPListener::test_bind_link_local
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m 'not network'
+}