summaryrefslogtreecommitdiff
path: root/dev-python/anyio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-06 10:13:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-06 10:13:38 +0100
commit8e3281f71945b4cccca5a44f2f467f3bff4ac45c (patch)
treed6bd38c3450c8e1dc5e12e2891351079338c4753 /dev-python/anyio
parent38d6f110ff1dfdd7c6f0b0baf0ed8b13191dcde3 (diff)
gentoo auto-resync : 06:07:2023 - 10:13:38
Diffstat (limited to 'dev-python/anyio')
-rw-r--r--dev-python/anyio/Manifest2
-rw-r--r--dev-python/anyio/anyio-3.7.1.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/anyio/Manifest b/dev-python/anyio/Manifest
index 08329dd6fba0..dea53adb993f 100644
--- a/dev-python/anyio/Manifest
+++ b/dev-python/anyio/Manifest
@@ -1,3 +1,5 @@
DIST anyio-3.7.0.tar.gz 142737 BLAKE2B f27b6c854f8861c760a922542471b5d7714cd54da0fa999a6efc8e394b49e538e7689147834a4076e1970932416fabe820923c2155048d943eee697454771c8f SHA512 0793012dc364d2bb27ebae8a23f275ecd24d444de750fbebcb72e70ca465a3be9c69938543e1a3c686abfff3ed9036974b38e3886fb24a110a9ef307a82d3f0b
+DIST anyio-3.7.1.tar.gz 142927 BLAKE2B 80a093943fbd23069e9511a83b3eb1e27f2863b11e184709f92cab2dfebc05ea3c291d22be4b1e79d00ae52e10009d5fb2c664730009b40e2b666587538d0ca5 SHA512 067bbffa9e0d6ce339a4999a677c857e839aa3bf5a056d841fec8cbd3be17023c9158df907ff66b9a5437a78158bc9bbb3b9ebe30c57ef98660642bc057d7d10
EBUILD anyio-3.7.0.ebuild 1986 BLAKE2B 85f7fefe0a9556e5bedafd5c325ca8f7316b8a9a60ee6c4550391beff042bcfa08d74672de61f737cd26315a3a96d5c57b5bd316f567ed1f1b7f6a76f1496a44 SHA512 6941087f75eccd2b7f7aa255d91387782e7367a2e933f0a37f9364d6c4c21be3b16b63526cdcfcb477f88450468c98484dde9e56a1a0606ad84909c4be3ed52d
+EBUILD anyio-3.7.1.ebuild 2039 BLAKE2B f4697939a0dd10ab113d9cd9bc3564eac1181160d084898419fade65eca97820a90b80bcdce9cb786dff3d63d65eb8d0db43853e29e1c2a2cb5204dd5e4379b4 SHA512 c8577ca3d38d97aed9bd99492b26740a8f53f71da3dff8aeb0688589e9101fda5099e911f6e37fa3ad0e4fa3f32fe710523dd2fd6ce3a01223a6c356afa93d69
MISC metadata.xml 1422 BLAKE2B 63acae587e7088e33ee5eb93a2a222899e54a5eb511118794f88e7c5a012d10983eb925427688a0b509b094e30a9cc9acc5f0c1765ea73e569161e0c30722000 SHA512 e0b540d5d739b7673a5a8682477f209f8b3648aad06a1c0610543a2e9dcbeca1cb1e52212d8088a5987a1c3bc3152cc5984ad5b5d0706fcdb5866b22de07b1eb
diff --git a/dev-python/anyio/anyio-3.7.1.ebuild b/dev-python/anyio/anyio-3.7.1.ebuild
new file mode 100644
index 000000000000..f998d1018fa3
--- /dev/null
+++ b/dev-python/anyio/anyio-3.7.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Compatibility layer for multiple asynchronous event loop implementations"
+HOMEPAGE="
+ https://github.com/agronholm/anyio/
+ https://pypi.org/project/anyio/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+ >=dev-python/idna-2.8[${PYTHON_USEDEP}]
+ >=dev-python/sniffio-1.1[${PYTHON_USEDEP}]
+"
+# On amd64, let's get more test coverage by dragging in uvloop, but let's
+# not bother on other arches where uvloop may not be supported.
+BDEPEND="
+ >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-4.0[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ amd64? (
+ $(python_gen_cond_dep '
+ >=dev-python/uvloop-0.17[${PYTHON_USEDEP}]
+ ' python3_{10..11})
+ )
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ '>=dev-python/sphinx-rtd-theme-1.2.2' \
+ dev-python/sphinxcontrib-jquery \
+ dev-python/sphinx-autodoc-typehints
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires link-local IPv6 interface
+ tests/test_sockets.py::TestTCPListener::test_bind_link_local
+
+ # trio-0.22?
+ 'tests/test_sockets.py::TestTCPStream::test_connection_refused[trio-multi]'
+ 'tests/test_taskgroups.py::test_exception_group_children[trio]'
+ 'tests/test_taskgroups.py::test_exception_group_host[trio]'
+ 'tests/test_taskgroups.py::test_exception_group_filtering[trio]'
+ )
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ tests/test_fileio.py::TestPath::test_properties
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m 'not network'
+}