summaryrefslogtreecommitdiff
path: root/dev-python/anyio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-17 08:58:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-17 08:58:39 +0000
commit7278fa233720d99bfac63a408deeed0143a61dcc (patch)
treeb49f0eb33cd7b7bbd4d57ef2fd7890a5c5a93e82 /dev-python/anyio
parente65f4866ce8216f52dc1316fba72f6962683ebfe (diff)
gentoo auto-resync : 17:12:2023 - 08:58:39
Diffstat (limited to 'dev-python/anyio')
-rw-r--r--dev-python/anyio/Manifest2
-rw-r--r--dev-python/anyio/anyio-4.2.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/anyio/Manifest b/dev-python/anyio/Manifest
index 70c15b913a15..ef277510b176 100644
--- a/dev-python/anyio/Manifest
+++ b/dev-python/anyio/Manifest
@@ -1,5 +1,7 @@
DIST anyio-3.7.1.tar.gz 142927 BLAKE2B 80a093943fbd23069e9511a83b3eb1e27f2863b11e184709f92cab2dfebc05ea3c291d22be4b1e79d00ae52e10009d5fb2c664730009b40e2b666587538d0ca5 SHA512 067bbffa9e0d6ce339a4999a677c857e839aa3bf5a056d841fec8cbd3be17023c9158df907ff66b9a5437a78158bc9bbb3b9ebe30c57ef98660642bc057d7d10
DIST anyio-4.1.0.tar.gz 155773 BLAKE2B 39dae924a28dbe14552259f240d6b63d5d2cccfbbb8efefb4100956764ab0144863d6f71a82c02cf245e12430a7c76f187163d9c4aa1b3af291e932efac0e23d SHA512 073b2c2cf92b3c1d3d5588a2ea966d82c793559702b64ab60ace539cfa2c33cf24c48ed06f0297ec3e0cca9b1ead59a995f7f59d2b3f2d75e43bdb16f927bea7
+DIST anyio-4.2.0.tar.gz 158770 BLAKE2B 10ae621872edb27727c8931904c84f41dc18ef0cc4cce1ea18c957d479be24b1a4ffb15d8a9e2b4338663fdbc2a989e5772ba1bd2076f9f0b22f6f5c4feef4bc SHA512 a6f3cbedbfa063a5cf031cd833e6da7a23ee37dbdae8d47ccdfb09c61a73c186267f1a33ba6b4936cac7fb4c970f5488ff1464295e5ffa452952732ac0468d65
EBUILD anyio-3.7.1.ebuild 2031 BLAKE2B 92d72a3c4833070582501bd18646c41c8d1a8551adae6dda13ea3fd7de20d199a3e3bcf5d8326d6c998c7ad9bf1d38291b05ad970c2c74b0698b66d9ca9c3c8b SHA512 233f500a7a0e2b2b7c371ee7a2ecbaa3ee5e52d1c557c5d9d94e6098590175a305a45960036a9106a2b56c8ec1cb84ba500221d473224ee30519f47119d7fc94
EBUILD anyio-4.1.0.ebuild 1595 BLAKE2B e398a23691a4dc1236d1fcd988edf683fb02fd5eafff6c778ee56627571a138009bae559bfaab2cbe695b1f310c321135a376f782ecb88e1f70773bf9a167a2c SHA512 b479209bbb5aa10cf295859a7057f6e59f94c8ed18254bff8dd58109fea873b8287f92cb44f073001050583276808fdf1b2fda60eae09fb721be6276ba88f3ff
+EBUILD anyio-4.2.0.ebuild 1692 BLAKE2B 555fa9281bd699f87c99cd9cbd2b7916219bbd9d07dd05cece662fd2bab0949921ace8367fc36177f087b8444eb0623f33438db90aaa8032196c9b05a86e57b7 SHA512 a0adbe45e3df73892877e3af076c6d4faccacb899e5cf0afb45c5d9018402c619eb7f40e44100c6a369a3c83ddbba339ddcdd3013f95abc7b2dd306bf952d507
MISC metadata.xml 1422 BLAKE2B 63acae587e7088e33ee5eb93a2a222899e54a5eb511118794f88e7c5a012d10983eb925427688a0b509b094e30a9cc9acc5f0c1765ea73e569161e0c30722000 SHA512 e0b540d5d739b7673a5a8682477f209f8b3648aad06a1c0610543a2e9dcbeca1cb1e52212d8088a5987a1c3bc3152cc5984ad5b5d0706fcdb5866b22de07b1eb
diff --git a/dev-python/anyio/anyio-4.2.0.ebuild b/dev-python/anyio/anyio-4.2.0.ebuild
new file mode 100644
index 000000000000..340e1ed5c7c2
--- /dev/null
+++ b/dev-python/anyio/anyio-4.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Compatibility layer for multiple asynchronous event loop implementations"
+HOMEPAGE="
+ https://github.com/agronholm/anyio/
+ https://pypi.org/project/anyio/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/exceptiongroup-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.8[${PYTHON_USEDEP}]
+ >=dev-python/sniffio-1.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+# On amd64, let's get more test coverage by dragging in uvloop, but let's
+# not bother on other arches where uvloop may not be supported.
+BDEPEND="
+ >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-4.0[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.23[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ amd64? (
+ $(python_gen_cond_dep '
+ >=dev-python/uvloop-0.17[${PYTHON_USEDEP}]
+ ' python3_{10..12})
+ )
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ '>=dev-python/sphinx-rtd-theme-1.2.2' \
+ dev-python/sphinxcontrib-jquery \
+ dev-python/sphinx-autodoc-typehints
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires link-local IPv6 interface
+ tests/test_sockets.py::TestTCPListener::test_bind_link_local
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m 'not network'
+}