summaryrefslogtreecommitdiff
path: root/dev-python/anyio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-15 00:01:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-15 00:01:28 +0100
commit514c44bb9cc421df9c323acbad430cbb6ee5b89a (patch)
tree22621125c9bc9177d5339f093f57cb928531f33f /dev-python/anyio
parent59c2499e0c9720169c9d5a02168c51c807a21467 (diff)
gentoo auto-resync : 15:05:2024 - 00:01:27
Diffstat (limited to 'dev-python/anyio')
-rw-r--r--dev-python/anyio/Manifest2
-rw-r--r--dev-python/anyio/anyio-4.3.0-r1.ebuild26
2 files changed, 24 insertions, 4 deletions
diff --git a/dev-python/anyio/Manifest b/dev-python/anyio/Manifest
index 2c522ca69b96..8fcf05c453ad 100644
--- a/dev-python/anyio/Manifest
+++ b/dev-python/anyio/Manifest
@@ -1,4 +1,4 @@
DIST anyio-4.3.0.tar.gz 159642 BLAKE2B 33b300d1da37137d45b311f8424c022d19518c207c39ec6f8bd3e42432cf1457f2d533eadeaa1e21853ed1b25a4f58818fc595e8588489722846f8a8d72262dc SHA512 26ff552a03b24b63c7c99cffcec61e97289eacba3ad2fc7a3c1dde8cfaffd9a8d621b867429901c12d7cef912d3807db134dbeb9c5ba619921160f6d5df4d02f
-EBUILD anyio-4.3.0-r1.ebuild 1747 BLAKE2B f774bbc2caf5d31511b117c16a0cf2daffcd1109dd1ca6a87dda2c4c3bf55d48fc3cb4db57d192956cd887bbcffde324e6f177d7ce1539ed969a1dd9c094c199 SHA512 479ccf1860356a8264ca3aa600ce7ab959959ee98b282db41237c1a3c11acbf57eb56f29bcd81d3b5ba7682a5683d2ab9bd630a5769291b3211a1e04e918cb18
+EBUILD anyio-4.3.0-r1.ebuild 2259 BLAKE2B 0a13245b624d44c48667f6146dd98b27fc22b6ced6ef90f45272839d96498dbbf1992598d16d95a6df4c2fedebea112f7a083d804bae52ba53140e287d32f327 SHA512 9421f588137a848a84f955d95d43b8c295d38edfe75327e7e049bbaacfc1f4009e8b32bd1fa4ef4a22811f4cdb5a8dbc66a13fa46590076e42f479f0accc4371
EBUILD anyio-4.3.0.ebuild 1684 BLAKE2B 82452731d1288270c4d6229f5a8aedf5e930f292ad4df17e145fa4239390dc9172623fa33c464893bc371c74023c7ffe7fc1e6801a4cbd09872ab6c3def463c8 SHA512 478925f2d70e8c5130f75a2650da30b5c8e772a79d25d2dc73d5eafb4d9ad6e8afaa23d94074993d14b1928b0aefd53fc6fc8840363a2ec514142a83f5c9039d
MISC metadata.xml 1422 BLAKE2B 63acae587e7088e33ee5eb93a2a222899e54a5eb511118794f88e7c5a012d10983eb925427688a0b509b094e30a9cc9acc5f0c1765ea73e569161e0c30722000 SHA512 e0b540d5d739b7673a5a8682477f209f8b3648aad06a1c0610543a2e9dcbeca1cb1e52212d8088a5987a1c3bc3152cc5984ad5b5d0706fcdb5866b22de07b1eb
diff --git a/dev-python/anyio/anyio-4.3.0-r1.ebuild b/dev-python/anyio/anyio-4.3.0-r1.ebuild
index 5636aa635281..b4a410314649 100644
--- a/dev-python/anyio/anyio-4.3.0-r1.ebuild
+++ b/dev-python/anyio/anyio-4.3.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
inherit distutils-r1 pypi
@@ -35,8 +35,10 @@ BDEPEND="
>=dev-python/hypothesis-4.0[${PYTHON_USEDEP}]
>=dev-python/psutil-5.9[${PYTHON_USEDEP}]
>=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
- >=dev-python/trio-0.23[${PYTHON_USEDEP}]
dev-python/trustme[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/trio-0.23[${PYTHON_USEDEP}]
+ ' 3.{10..12})
amd64? (
$(python_gen_cond_dep '
>=dev-python/uvloop-0.17[${PYTHON_USEDEP}]
@@ -57,6 +59,24 @@ python_test() {
tests/test_sockets.py::TestTCPListener::test_bind_link_local
)
+ local filter=()
+ if ! has_version ">=dev-python/trio-0.23[${PYTHON_USEDEP}]"; then
+ filter+=( -k "not trio" )
+ EPYTEST_DESELECT+=(
+ tests/test_pytest_plugin.py::test_plugin
+ tests/test_pytest_plugin.py::test_autouse_async_fixture
+ tests/test_pytest_plugin.py::test_cancel_scope_in_asyncgen_fixture
+ )
+ fi
+
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ 'tests/test_fileio.py::TestPath::test_properties[asyncio]'
+ )
+ ;;
+ esac
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -m 'not network'
+ epytest -m 'not network' "${filter[@]}"
}