summaryrefslogtreecommitdiff
path: root/dev-python/anyio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-31 16:11:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-31 16:11:27 +0100
commit260722f712fe06c113e7b13ad2e924ed14aaf0c4 (patch)
treea29845500e555a40458a70b7ed2896588134df2a /dev-python/anyio
parent0fde6d7108b1ee9fc6ad186eff4978faa255db20 (diff)
gentoo auto-resync : 31:08:2023 - 16:11:26
Diffstat (limited to 'dev-python/anyio')
-rw-r--r--dev-python/anyio/Manifest2
-rw-r--r--dev-python/anyio/anyio-4.0.0.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/anyio/Manifest b/dev-python/anyio/Manifest
index 4b58a1df2b8b..b804d9570f09 100644
--- a/dev-python/anyio/Manifest
+++ b/dev-python/anyio/Manifest
@@ -1,3 +1,5 @@
DIST anyio-3.7.1.tar.gz 142927 BLAKE2B 80a093943fbd23069e9511a83b3eb1e27f2863b11e184709f92cab2dfebc05ea3c291d22be4b1e79d00ae52e10009d5fb2c664730009b40e2b666587538d0ca5 SHA512 067bbffa9e0d6ce339a4999a677c857e839aa3bf5a056d841fec8cbd3be17023c9158df907ff66b9a5437a78158bc9bbb3b9ebe30c57ef98660642bc057d7d10
+DIST anyio-4.0.0.tar.gz 153297 BLAKE2B 680c3472525a777dc2af63241ef1b6f90bcc2224d944fc04aef519d0d97bb5845c7b3faddb116b20cfb1a61303bcf91290b1f2544a3cfcb08f3488a70b275c8a SHA512 b0ec5aa912c973206d8677a6aba25957cd669dfe890ee7d39af064f1620f9a5103a39bd6d35f4ea680b86d13964daf1e982ac6873bf5903eeaaa6e74ea974948
EBUILD anyio-3.7.1.ebuild 2031 BLAKE2B 92d72a3c4833070582501bd18646c41c8d1a8551adae6dda13ea3fd7de20d199a3e3bcf5d8326d6c998c7ad9bf1d38291b05ad970c2c74b0698b66d9ca9c3c8b SHA512 233f500a7a0e2b2b7c371ee7a2ecbaa3ee5e52d1c557c5d9d94e6098590175a305a45960036a9106a2b56c8ec1cb84ba500221d473224ee30519f47119d7fc94
+EBUILD anyio-4.0.0.ebuild 1638 BLAKE2B 1d0aadb783179511b7e72175d50a5b785c874967558de6b0a5f35ef0127b215a0fac2cbe44c60e0b8decbaddd4ddc5a877a6c848feea7ba6be4097a3ca63d152 SHA512 dd0ffc4625dcde7634af793ab330b1af45f7ff1c083d53a5cbe86008a0f4371b971584f6dccb5dd39dac7e49c79d36ba30e8f150fb76d8297b97f3c38e260293
MISC metadata.xml 1422 BLAKE2B 63acae587e7088e33ee5eb93a2a222899e54a5eb511118794f88e7c5a012d10983eb925427688a0b509b094e30a9cc9acc5f0c1765ea73e569161e0c30722000 SHA512 e0b540d5d739b7673a5a8682477f209f8b3648aad06a1c0610543a2e9dcbeca1cb1e52212d8088a5987a1c3bc3152cc5984ad5b5d0706fcdb5866b22de07b1eb
diff --git a/dev-python/anyio/anyio-4.0.0.ebuild b/dev-python/anyio/anyio-4.0.0.ebuild
new file mode 100644
index 000000000000..74d0dbd87994
--- /dev/null
+++ b/dev-python/anyio/anyio-4.0.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Compatibility layer for multiple asynchronous event loop implementations"
+HOMEPAGE="
+ https://github.com/agronholm/anyio/
+ https://pypi.org/project/anyio/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.2[${PYTHON_USEDEP}]
+ ' 3.10)
+ >=dev-python/idna-2.8[${PYTHON_USEDEP}]
+ >=dev-python/sniffio-1.1[${PYTHON_USEDEP}]
+"
+# On amd64, let's get more test coverage by dragging in uvloop, but let's
+# not bother on other arches where uvloop may not be supported.
+BDEPEND="
+ >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-4.0[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ amd64? (
+ $(python_gen_cond_dep '
+ >=dev-python/uvloop-0.17[${PYTHON_USEDEP}]
+ ' python3_{10..11})
+ )
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ '>=dev-python/sphinx-rtd-theme-1.2.2' \
+ dev-python/sphinxcontrib-jquery \
+ dev-python/sphinx-autodoc-typehints
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires link-local IPv6 interface
+ tests/test_sockets.py::TestTCPListener::test_bind_link_local
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m 'not network'
+}