summaryrefslogtreecommitdiff
path: root/dev-python/anyio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-22 14:47:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-22 14:47:12 +0100
commit1802160f23e91c618b3c7379fd99127682cfce19 (patch)
tree094c5349b2f0bd88633709f2f1ad322398475815 /dev-python/anyio
parent439c34b3917f0757b9c83eb64a687cac0d477140 (diff)
gentoo auto-resync : 22:09:2024 - 14:47:12
Diffstat (limited to 'dev-python/anyio')
-rw-r--r--dev-python/anyio/Manifest2
-rw-r--r--dev-python/anyio/anyio-4.6.0.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/anyio/Manifest b/dev-python/anyio/Manifest
index 7673f5f695a2..c4090251ca35 100644
--- a/dev-python/anyio/Manifest
+++ b/dev-python/anyio/Manifest
@@ -1,6 +1,8 @@
AUX anyio-4.4.0-py313.patch 3403 BLAKE2B d58254482e73351f19bdc63dbb0aac98e472a780e5e646caed3ded574a17346ed9f9a25e792d4877b85f13282bb0e0f2159ec561fc0be936f1fc07bcabfa3c54 SHA512 37d248f1a4aa9b1644c0c6568789852aeba062b3c80aeb7f6b06a0e6d4b1c92b6f289f0d23d5479a59b9329a8b7e9587a79e440e381dae2ed99b66ff3fae4637
DIST anyio-4.4.0.tar.gz 163930 BLAKE2B a37b8bc05e43cf1a4bc3f15ab399c78c7a76235942d776848307b189898973e46ddfb553bd20da154dc740d8b8bb93050ac460e56607b686bc2936c5a1e09332 SHA512 db8ad7a4faf257269de9975c3a6325023a95255a8bfe1a9642221080f44a2487160f3c0e8b220d637816e9eb3641550393a3c80b23bddafc33fd9ebe9a23b33d
DIST anyio-4.5.0.tar.gz 169376 BLAKE2B be8b68729b9ad3c6ff39844617ebabf2b36facee5b1e4cbc9933fb6315a70daec785d2aebab9dc29d387987bee20bc6bf56f3befa9a997a4caa2ef9d7dffcc23 SHA512 12dbcc59888c555381589a820713c636f0f1a09d7999746ce5fbbdaa9a4cad5644510d036287d202db617ee16d59231a8edc824b003056bad22a189b5863c6f5
+DIST anyio-4.6.0.tar.gz 170983 BLAKE2B 686cb9b622cba29d02fe6e440502de80c159dc40547124aed79eb7558fe147fa62f378745c2aa5487ca1ea7c24e1f3c6167f8343236dbb7e0876d95f741c46ec SHA512 4828198d3e2b2924b3490c305dcaddc14b5746b29a0cb36f75913f897254fed0ac46e075a3c04bf164a7d4d597b0dcdd991fe5cb26ffce477d029db7ff924f38
EBUILD anyio-4.4.0-r1.ebuild 2337 BLAKE2B f82fef9559b6d3354e4b5596219844ee051b155a52daac734691f02052661410cc8caa6054ec88d5543d09f51dd19dc597d2d869e0cb9d368e13422bf0287856 SHA512 e4eac2aa027aadba42c21eb495473bbcc50f810e7423685a89d35707e9c7a1ba5408a04c4503d76ba4bff5e666445a7b32cd685ee94e5fe8cba68374c1205d48
EBUILD anyio-4.5.0.ebuild 2127 BLAKE2B 975acdb2b688cd60c79d633864a0b3df7af0f364145a46c6af397f37c983d0f7b91bdd1cdb813ec6e6ef776094f6b71ca38a995bea94e828bd69388c93c5eeea SHA512 bd5ebbc66b589cdb8685f96b8dc9e947001d95a9b1cd40174a6990611e032ad591b8b5a5496bd5edaa5fa594ed222d282d8174db2f4f8a82690b3446ca5e4fa3
+EBUILD anyio-4.6.0.ebuild 2127 BLAKE2B 975acdb2b688cd60c79d633864a0b3df7af0f364145a46c6af397f37c983d0f7b91bdd1cdb813ec6e6ef776094f6b71ca38a995bea94e828bd69388c93c5eeea SHA512 bd5ebbc66b589cdb8685f96b8dc9e947001d95a9b1cd40174a6990611e032ad591b8b5a5496bd5edaa5fa594ed222d282d8174db2f4f8a82690b3446ca5e4fa3
MISC metadata.xml 1422 BLAKE2B 63acae587e7088e33ee5eb93a2a222899e54a5eb511118794f88e7c5a012d10983eb925427688a0b509b094e30a9cc9acc5f0c1765ea73e569161e0c30722000 SHA512 e0b540d5d739b7673a5a8682477f209f8b3648aad06a1c0610543a2e9dcbeca1cb1e52212d8088a5987a1c3bc3152cc5984ad5b5d0706fcdb5866b22de07b1eb
diff --git a/dev-python/anyio/anyio-4.6.0.ebuild b/dev-python/anyio/anyio-4.6.0.ebuild
new file mode 100644
index 000000000000..15e58ff7d1b4
--- /dev/null
+++ b/dev-python/anyio/anyio-4.6.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Compatibility layer for multiple asynchronous event loop implementations"
+HOMEPAGE="
+ https://github.com/agronholm/anyio/
+ https://pypi.org/project/anyio/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/idna-2.8[${PYTHON_USEDEP}]
+ >=dev-python/sniffio-1.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+# On amd64, let's get more test coverage by dragging in uvloop, but let's
+# not bother on other arches where uvloop may not be supported.
+BDEPEND="
+ >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/exceptiongroup-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-4.0[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/trio-0.26.1[${PYTHON_USEDEP}]
+ ' 3.{10..13})
+ amd64? (
+ $(python_gen_cond_dep '
+ >=dev-python/uvloop-0.21.0_beta1[${PYTHON_USEDEP}]
+ ' python3_{10..13})
+ )
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ '>=dev-python/sphinx-rtd-theme-1.2.2' \
+ dev-python/sphinxcontrib-jquery \
+ dev-python/sphinx-autodoc-typehints
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires link-local IPv6 interface
+ tests/test_sockets.py::TestTCPListener::test_bind_link_local
+ )
+
+ local filter=()
+ if ! has_version ">=dev-python/trio-0.26.1[${PYTHON_USEDEP}]"; then
+ filter+=( -k "not trio" )
+ EPYTEST_DESELECT+=(
+ tests/test_pytest_plugin.py::test_plugin
+ tests/test_pytest_plugin.py::test_autouse_async_fixture
+ tests/test_pytest_plugin.py::test_cancel_scope_in_asyncgen_fixture
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m 'not network' "${filter[@]}"
+}