summaryrefslogtreecommitdiff
path: root/dev-python/antlr4-python3-runtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-05 10:24:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-05 10:24:06 +0100
commita0f09b2c947909b614c52fcfbdce964469404101 (patch)
tree675a5547be05cbc1b2f8a23d007dbf5ade80ffc7 /dev-python/antlr4-python3-runtime
parentdff5148a375dbe1b3ec2c5e5e4fa482bd1224c98 (diff)
gentoo auto-resync : 05:09:2022 - 10:24:06
Diffstat (limited to 'dev-python/antlr4-python3-runtime')
-rw-r--r--dev-python/antlr4-python3-runtime/Manifest2
-rw-r--r--dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.11.1.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/antlr4-python3-runtime/Manifest b/dev-python/antlr4-python3-runtime/Manifest
index 7bd4821e9395..e289a794e581 100644
--- a/dev-python/antlr4-python3-runtime/Manifest
+++ b/dev-python/antlr4-python3-runtime/Manifest
@@ -1,3 +1,5 @@
DIST antlr-4.10.1.tar.gz 4599964 BLAKE2B 72688b3835350da11c015558a2840428fe69332a7b48992e118cb410005efce6ca5e02e8e5b1cf5edbf2cea506ec30fe516cce5061c52febbdb71f735c1c2cd1 SHA512 d950171d279b57b0fa977c77dd33e56848ca0aaf7f6ba40e5d49d69d5963e4c2e36fde5ee89e98c594064a909396d6fed9cc20129c3a1895d864eb889581e982
+DIST antlr-4.11.1.gh.tar.gz 4383139 BLAKE2B ac6e49ae8d4d44923e40eba98fa2c850cb594929ae1a29223678377aabe6f35d57f95e125393aa6b7145828c876442608883356b594ab43346c891ca932d9fd5 SHA512 a81f2ebcbcb6e63eb651731ceafab55f66401a3da0a6b2688cfe96d3bda299542dab5b05aaf4c8a8520ba32891b23adbf912011a4e45afae492a2a350d333ae9
EBUILD antlr4-python3-runtime-4.10.1.ebuild 627 BLAKE2B 3379bd958c63490aff7c337b457401558c7e60ab5cc1959098b7b717c78bfd36712abba605b68c994bdb18eb334e5730204bc91c7fb355e3c66285d764b2e398 SHA512 04507c76a6de8f9dada63adada870c30344d742376eeeb1fe5a77464fffc1111942502e21e0f4c22265bba2f7c3a333410b71e10ad5a8aab5348c9baf1ba0e6e
+EBUILD antlr4-python3-runtime-4.11.1.ebuild 630 BLAKE2B c1de6fd98c5111810c385b357c80e69548f268936d8b944a0827ec777f99cde9b8ef3f3ae9f8e220d0a31e1252a24e4dd1d44e8655571cf8577638b8ef05a496 SHA512 41aac84e4362e1af1497514182ab7bc96a4e4c8be9477c25756d7a7a1e3688a11e51758efba1950cff6e3075de493ccdaed73ef874ae12a91f42e8c17107be16
MISC metadata.xml 475 BLAKE2B 12dd34c09572017544a99c3985f6a7ad6c163f999f43fbc7ef4903456fe2d7fc59a8571fa3337ebe5a49eb6efab0a657a1b82b484b55887c799af11c0e64e716 SHA512 44ddd959d9f77d7beb97f84888db46ca468ed79ca844f89bbcac57366f42e1c2a1689497e2c25a659d2a63026b3c85f8348a43ee0213573d4a85cbf77fdfb993
diff --git a/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.11.1.ebuild b/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.11.1.ebuild
new file mode 100644
index 000000000000..13f1fbcbd807
--- /dev/null
+++ b/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.11.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 runtime for ANTLR"
+HOMEPAGE="
+ https://www.antlr.org/
+ https://github.com/antlr/antlr4/
+ https://pypi.org/project/antlr4-python3-runtime/
+"
+SRC_URI="
+ https://github.com/antlr/antlr4/archive/${PV}.tar.gz
+ -> antlr-${PV}.gh.tar.gz
+"
+S="${WORKDIR}/antlr4-${PV}/runtime/Python3"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" tests/run.py -v || die "Tests failed with ${EPYTHON}"
+}