summaryrefslogtreecommitdiff
path: root/dev-python/antlr4-python3-runtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/antlr4-python3-runtime
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/antlr4-python3-runtime')
-rw-r--r--dev-python/antlr4-python3-runtime/Manifest2
-rw-r--r--dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.10.1.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/antlr4-python3-runtime/Manifest b/dev-python/antlr4-python3-runtime/Manifest
index a8a86bc9c0b5..f8fefba482d0 100644
--- a/dev-python/antlr4-python3-runtime/Manifest
+++ b/dev-python/antlr4-python3-runtime/Manifest
@@ -1,5 +1,7 @@
+DIST antlr-4.10.1.tar.gz 4599964 BLAKE2B 72688b3835350da11c015558a2840428fe69332a7b48992e118cb410005efce6ca5e02e8e5b1cf5edbf2cea506ec30fe516cce5061c52febbdb71f735c1c2cd1 SHA512 d950171d279b57b0fa977c77dd33e56848ca0aaf7f6ba40e5d49d69d5963e4c2e36fde5ee89e98c594064a909396d6fed9cc20129c3a1895d864eb889581e982
DIST antlr-4.10.tar.gz 4599769 BLAKE2B 030a4cef752aec2199a816717e242b12245d869634e8c3b94825990f1ad99c000d8bc247c95b182b8146ae57f705a437b3a43fe91f9855958ed2f2115cdbef40 SHA512 af865442047ad8880172e62d17b7eb68d5eeda668ed55995b05cae69ee5e47a89d7a757ddd429ab8d93f5bad50269f0e3dc2e9cf121a9b3d6a87674787858309
DIST antlr-4.9.3.tar.gz 4640242 BLAKE2B fb58f5e533051cb2c439c32f0462c1d463c99df862ba7e1a37a1c61378ab36a9edb9525c2a342de5b517da6f02d8291de5976c550932314f3464aad1a778afb9 SHA512 61452404c9639b5a0908cda16605f17c0fed0c9adfc3278c7408f9971420e9d1fe8f9e974e0826c2e3e780fdd83324094c0246cd5b28fa63f5686b094ea08127
+EBUILD antlr4-python3-runtime-4.10.1.ebuild 627 BLAKE2B 3379bd958c63490aff7c337b457401558c7e60ab5cc1959098b7b717c78bfd36712abba605b68c994bdb18eb334e5730204bc91c7fb355e3c66285d764b2e398 SHA512 04507c76a6de8f9dada63adada870c30344d742376eeeb1fe5a77464fffc1111942502e21e0f4c22265bba2f7c3a333410b71e10ad5a8aab5348c9baf1ba0e6e
EBUILD antlr4-python3-runtime-4.10.ebuild 540 BLAKE2B 04881ad4a4fd8f3c32f909ff7418996dc098a40048f052f626785e884349e73ba051a8c89f29ea23c1542ee6802e2785c3ebee513a74d7d213dfba0f7da32443 SHA512 6946bc4502a74c7da3a5e5f9043d4f983518a6cc3cecc955a07c45714372afff65fee25ae226adf078baead318de3980bdc4c158a911c392096bc1d8a221007f
EBUILD antlr4-python3-runtime-4.9.3.ebuild 534 BLAKE2B 13394f582021232d8a283bcb7cba8d0dc608d7200e95067c8d19a3a20c364ad60df42a7195af869e97a954f15f190c46816a6fdddbe47abf5c2b0fae2f90456a SHA512 64f383bfbfc4fc0fa2b8dae0e9f41d472183875cfcc078f8cd2b9be9e17cdcbd4718d874792286f91386fbff840e043ff10ec5722ff8605f4ce09400363c115c
MISC metadata.xml 475 BLAKE2B 12dd34c09572017544a99c3985f6a7ad6c163f999f43fbc7ef4903456fe2d7fc59a8571fa3337ebe5a49eb6efab0a657a1b82b484b55887c799af11c0e64e716 SHA512 44ddd959d9f77d7beb97f84888db46ca468ed79ca844f89bbcac57366f42e1c2a1689497e2c25a659d2a63026b3c85f8348a43ee0213573d4a85cbf77fdfb993
diff --git a/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.10.1.ebuild b/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.10.1.ebuild
new file mode 100644
index 000000000000..9240a6802564
--- /dev/null
+++ b/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.10.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 runtime for ANTLR"
+HOMEPAGE="
+ https://www.antlr.org/
+ https://github.com/antlr/antlr4/
+ https://pypi.org/project/antlr4-python3-runtime/
+"
+SRC_URI="
+ https://github.com/antlr/antlr4/archive/${PV}.tar.gz
+ -> antlr-${PV}.tar.gz
+"
+S="${WORKDIR}/antlr4-${PV}/runtime/Python3"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" tests/run.py -v || die "Tests failed with ${EPYTHON}"
+}