summaryrefslogtreecommitdiff
path: root/dev-python/antlr4-python3-runtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-22 08:56:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-22 08:56:17 +0100
commit07a79a268edfbac4dba8c66eff20cbdc2aac0f6a (patch)
treebc6688a3cc8c802970aa5e29936310ae9b76ccda /dev-python/antlr4-python3-runtime
parent470949042cc90856adb62f2671e04e3165fc8063 (diff)
gentoo auto-resync : 22:05:2023 - 08:56:17
Diffstat (limited to 'dev-python/antlr4-python3-runtime')
-rw-r--r--dev-python/antlr4-python3-runtime/Manifest2
-rw-r--r--dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.13.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/antlr4-python3-runtime/Manifest b/dev-python/antlr4-python3-runtime/Manifest
index b520956bad74..0a5841699922 100644
--- a/dev-python/antlr4-python3-runtime/Manifest
+++ b/dev-python/antlr4-python3-runtime/Manifest
@@ -1,3 +1,5 @@
DIST antlr-4.12.0.gh.tar.gz 4408352 BLAKE2B 9a7ba9149c459e5b6a7eec750d1623f10be4aa119479d93dbf7f3955176013ac3e56d3a95399460ed5170cf2bf01fff586852a84d2cb86fe04e89846211e39cd SHA512 2217509e8766ceee7b9e5fdee3a9972b1f42fb442bdf3e3c0a8027f88bc49508386adb5ea8a02c982ef2176e2b5e60669746a387ec426682d7f43bca28aa4b6f
+DIST antlr4-4.13.0.gh.tar.gz 4317288 BLAKE2B 7971b12a3d3fe50f50b9888a4de9cb7fdc28140c95a29fe00538a48da3434ec1c38643e7a1eb19457e0363b7e57747f5597081af59f653f7108f26f6515d8f35 SHA512 947ecca28712aa4dd98d7b7e0753e91881e55642f7951ca65a576b94db87440767a1b93d08e82db69ad527ee28bf89f0b2f9c0aaa604a999a7e48c163764ee12
EBUILD antlr4-python3-runtime-4.12.0.ebuild 635 BLAKE2B 2735bfaf0c54010519543bd64717f438e7a245ea14ed5e5f13ac7d5bbc431e0ad8d7e0d86d1ff848de10fdb2660157b507ca04110064b5b940d3832d334cb825 SHA512 f0920d4ac576fcf0cb15662d7457ed5f8ab4b48e7391dbab219c2ba4f37cc6cf3889fd511a66e53427c565a33b36df7573e04bd5e3c68a133c25860b5000c2f4
+EBUILD antlr4-python3-runtime-4.13.0.ebuild 645 BLAKE2B 61e4c24861ec9b1e1acb51441baa3d02ad7e59fcd11138a3aba1787b25712979bb2622eabfc14a95ffa79a344507fa788e5200da0bcbd01671967ab083313c8f SHA512 ddeddb3cb515cc5abbb6019a3d6fb6390485e50ba388c991ced1e3db8036d7e9ae0663e508572b4c0cf7a14d279c2dcad4fc457ad4105f659012f7f6dfd61162
MISC metadata.xml 475 BLAKE2B 12dd34c09572017544a99c3985f6a7ad6c163f999f43fbc7ef4903456fe2d7fc59a8571fa3337ebe5a49eb6efab0a657a1b82b484b55887c799af11c0e64e716 SHA512 44ddd959d9f77d7beb97f84888db46ca468ed79ca844f89bbcac57366f42e1c2a1689497e2c25a659d2a63026b3c85f8348a43ee0213573d4a85cbf77fdfb993
diff --git a/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.13.0.ebuild b/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.13.0.ebuild
new file mode 100644
index 000000000000..31dcc7c87016
--- /dev/null
+++ b/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.13.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=antlr4-${PV}
+DESCRIPTION="Python 3 runtime for ANTLR"
+HOMEPAGE="
+ https://www.antlr.org/
+ https://github.com/antlr/antlr4/
+ https://pypi.org/project/antlr4-python3-runtime/
+"
+SRC_URI="
+ https://github.com/antlr/antlr4/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/runtime/Python3"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" tests/run.py -v || die "Tests failed with ${EPYTHON}"
+}