summaryrefslogtreecommitdiff
path: root/dev-python/ansicolor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /dev-python/ansicolor
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'dev-python/ansicolor')
-rw-r--r--dev-python/ansicolor/Manifest5
-rw-r--r--dev-python/ansicolor/ansicolor-0.2.6-r1.ebuild25
-rw-r--r--dev-python/ansicolor/ansicolor-9999.ebuild30
-rw-r--r--dev-python/ansicolor/metadata.xml9
4 files changed, 50 insertions, 19 deletions
diff --git a/dev-python/ansicolor/Manifest b/dev-python/ansicolor/Manifest
index 12e0fd910c5f..b3564c968c16 100644
--- a/dev-python/ansicolor/Manifest
+++ b/dev-python/ansicolor/Manifest
@@ -1,4 +1,5 @@
DIST ansicolor-0.2.6.tar.gz 6224 BLAKE2B 38ffd0e9a88c886ebad25c4f0072f2f8f833e028c3bc14eb89252c1c0b501f973c9b3e371b4c605a3b98df33eb7203a963797d3ee56cf87b0afb927b19096fd5 SHA512 44c7dc6f621fc3044d4a52acb96e7e497578e025090633bfc8cbf686d7461da018f64502b477a6090e60747481f320cebaad00ee0776c9f4c52d4abbb1812121
+EBUILD ansicolor-0.2.6-r1.ebuild 709 BLAKE2B 6ccde11f2ca1d56d12bfa9a4b648de65ae157f8b6200faee202d46309a9e4e264b65bcd5433d30d0612e878b846559360468e1d89c1e4f8d99d9bcccf23e241c SHA512 79d39303212563c35305ff73df8d751b88c4bc8550ef2380ec3873dd958adb0a623af8ef96aa836b6487464bf74da79f60228c8a039b615a83b8e43b3ffd6b62
EBUILD ansicolor-0.2.6.ebuild 513 BLAKE2B 88bdf9a046248d159810ed78eb64bb6a84e3370a217dc37af207a0fd6820c47563f270c3b43ed28b02261902966ead2fff41679228c5a132880d6f3d68190fef SHA512 d5baba68ba67c30b249321616e6e5d4bc46bacac367c3d8fb3f3d17acbb69685c3d3e94185772886b73e3b9f21b6bf11340b29251b26f4320d8ae60c5ff6f398
-EBUILD ansicolor-9999.ebuild 649 BLAKE2B 5fe5fc92f67d6b04966ef498abe68d54414067797174fd2f1d5c4023f7b37fb0cf4bfb982d6b5085ab5bfc16a61347830335f9a1b045b894b9a5895974cf53f6 SHA512 9de36447f2948c90246f6347e79f2a461a389b598d74b82d4c937ab66d8f3152b57a0427c355428c7b13716ff9ed1a4b42c0e1a66d63b57175508e7cce9a516f
-MISC metadata.xml 298 BLAKE2B 4ca5c54a9b47e20ee8ed4520c011034049088aaa0bcb1ae7d37eb590c3f3b3d8296e71958dcb1b6342f69cb4e8edb443823bce0381f97cf80544bbe66473c122 SHA512 debf13987936d64adf35fcc48d08f306f13d2d719afb478e8c78a89eec873c17a0323a6cc7ce473c67077c5ec9ed97e8983dedd63e986e74702166c592d4a193
+EBUILD ansicolor-9999.ebuild 709 BLAKE2B 6ccde11f2ca1d56d12bfa9a4b648de65ae157f8b6200faee202d46309a9e4e264b65bcd5433d30d0612e878b846559360468e1d89c1e4f8d99d9bcccf23e241c SHA512 79d39303212563c35305ff73df8d751b88c4bc8550ef2380ec3873dd958adb0a623af8ef96aa836b6487464bf74da79f60228c8a039b615a83b8e43b3ffd6b62
+MISC metadata.xml 495 BLAKE2B 4abde6382c00405991e92ff16adaad5840999eb0d47d426991fed3528ad79d26973459c926c412bed73c402810000f4213e280a60f9720ee42e3dcfaaae1bd68 SHA512 22215a33ff2270d816624404e2f44e4553d8d03cfc1627f4475f61be0912d7b25fe740fda0317ea2ea8e85891f4e4f089b46275fec9d49672f129a16f5a076e8
diff --git a/dev-python/ansicolor/ansicolor-0.2.6-r1.ebuild b/dev-python/ansicolor/ansicolor-0.2.6-r1.ebuild
new file mode 100644
index 000000000000..25c10321fe62
--- /dev/null
+++ b/dev-python/ansicolor/ansicolor-0.2.6-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/numerodix/ansicolor.git"
+ # pypi tars don't include tests and github repo is missing release tags,
+ # so only enabling tests for 9999 at this time
+ distutils_enable_tests pytest
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Produce ansi color output and colored highlighting and diffing"
+HOMEPAGE="https://github.com/numerodix/ansicolor https://pypi.org/project/ansicolor/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
diff --git a/dev-python/ansicolor/ansicolor-9999.ebuild b/dev-python/ansicolor/ansicolor-9999.ebuild
index e5f2a4f1961f..25c10321fe62 100644
--- a/dev-python/ansicolor/ansicolor-9999.ebuild
+++ b/dev-python/ansicolor/ansicolor-9999.ebuild
@@ -1,27 +1,25 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
-inherit distutils-r1 git-r3
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/numerodix/ansicolor.git"
+ # pypi tars don't include tests and github repo is missing release tags,
+ # so only enabling tests for 9999 at this time
+ distutils_enable_tests pytest
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
DESCRIPTION="Produce ansi color output and colored highlighting and diffing"
HOMEPAGE="https://github.com/numerodix/ansicolor https://pypi.org/project/ansicolor/"
-EGIT_REPO_URI="https://github.com/numerodix/ansicolor.git"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS=""
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-python_test() {
- py.test -v || die "Test suite failed with ${EPYTHON}"
-}
diff --git a/dev-python/ansicolor/metadata.xml b/dev-python/ansicolor/metadata.xml
index 17e74d02f0c8..50b2ecb53677 100644
--- a/dev-python/ansicolor/metadata.xml
+++ b/dev-python/ansicolor/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>lucianposton@pm.me</email>
+ <name>Lucian Poston</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="github">numerodix/ansicolor</remote-id>
<remote-id type="pypi">ansicolor</remote-id>