summaryrefslogtreecommitdiff
path: root/dev-python/ansicolor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/ansicolor
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/ansicolor')
-rw-r--r--dev-python/ansicolor/Manifest4
-rw-r--r--dev-python/ansicolor/ansicolor-0.2.6.ebuild19
-rw-r--r--dev-python/ansicolor/ansicolor-9999.ebuild26
-rw-r--r--dev-python/ansicolor/metadata.xml16
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/ansicolor/Manifest b/dev-python/ansicolor/Manifest
new file mode 100644
index 000000000000..149341812461
--- /dev/null
+++ b/dev-python/ansicolor/Manifest
@@ -0,0 +1,4 @@
+DIST ansicolor-0.2.6.tar.gz 6224 BLAKE2B 38ffd0e9a88c886ebad25c4f0072f2f8f833e028c3bc14eb89252c1c0b501f973c9b3e371b4c605a3b98df33eb7203a963797d3ee56cf87b0afb927b19096fd5 SHA512 44c7dc6f621fc3044d4a52acb96e7e497578e025090633bfc8cbf686d7461da018f64502b477a6090e60747481f320cebaad00ee0776c9f4c52d4abbb1812121
+EBUILD ansicolor-0.2.6.ebuild 535 BLAKE2B 2535d178ffe05e959d87e699fdd214bf9ed5a3c04307b8ca2b5283dbc55241698575eb0a43e3fabf3793287887e8638f9993ff5178520d02e7e37f7f174ea3b4 SHA512 f889c6993b0444b58d06ee0223283391ab58320eefdfdf507f6dec26eb48bf9517a37ac55ab2ec36197e067bf0167cd80bab7ab2ef799ec61cfaed3f47325d67
+EBUILD ansicolor-9999.ebuild 644 BLAKE2B 7bd29e4fa18fe6d5bb25af09cf820e8871f7d6590b461dc2a42fb1274b47e8cf20c076306026f7b3138c8774965d3e2da039eeb402388f3c05bc5f719ebbac8c SHA512 84126d0480ab6946765fb94189d411dbf6324dc10360c4e170a000576441868d95ecde5524fb2ecfefe9159821f0485d885860e0cfb0d4cfd194cce2ffacf377
+MISC metadata.xml 497 BLAKE2B ce249e4bcd8f3e7eacfbe1ce27ee5fc2746173417a81dc51ea3234632e436c256bb5be663d9a8e0a514378c084a6beffda8b30112d82be96c1f6d1748f78d8a7 SHA512 539ed7d24279e0c9a23166e4c2a19326c6bbeeebc17b5d55b0ebf45621005c47bb6cd7f434a30d93c585b7444b327f9e87389f0a63cdf000ea8e13ae23625400
diff --git a/dev-python/ansicolor/ansicolor-0.2.6.ebuild b/dev-python/ansicolor/ansicolor-0.2.6.ebuild
new file mode 100644
index 000000000000..a3255104980f
--- /dev/null
+++ b/dev-python/ansicolor/ansicolor-0.2.6.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Produce ansi color output and colored highlighting and diffing"
+HOMEPAGE="https://github.com/numerodix/ansicolor https://pypi.org/project/ansicolor/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/ansicolor/ansicolor-9999.ebuild b/dev-python/ansicolor/ansicolor-9999.ebuild
new file mode 100644
index 000000000000..2977c375d9af
--- /dev/null
+++ b/dev-python/ansicolor/ansicolor-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Produce ansi color output and colored highlighting and diffing"
+HOMEPAGE="https://github.com/numerodix/ansicolor https://pypi.org/project/ansicolor/"
+EGIT_REPO_URI="https://github.com/numerodix/ansicolor.git"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ py.test -v || die "Test suite failed with ${EPYTHON}"
+}
diff --git a/dev-python/ansicolor/metadata.xml b/dev-python/ansicolor/metadata.xml
new file mode 100644
index 000000000000..6baace5d033a
--- /dev/null
+++ b/dev-python/ansicolor/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>itumaykin+gentoo@gmail.com</email>
+ <name>Coacher</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">numerodix/ansicolor</remote-id>
+ <remote-id type="pypi">ansicolor</remote-id>
+ </upstream>
+</pkgmetadata>