summaryrefslogtreecommitdiff
path: root/dev-python/ansicolor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
commit06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (patch)
tree8d58c1f4b049da677b33209b072f2b3057268fe0 /dev-python/ansicolor
parent99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (diff)
gentoo resync : 02.03.2018
Diffstat (limited to 'dev-python/ansicolor')
-rw-r--r--dev-python/ansicolor/Manifest1
-rw-r--r--dev-python/ansicolor/ansicolor-9999.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/ansicolor/Manifest b/dev-python/ansicolor/Manifest
index d1c2358465c0..52b1bd99f652 100644
--- a/dev-python/ansicolor/Manifest
+++ b/dev-python/ansicolor/Manifest
@@ -2,4 +2,5 @@ DIST ansicolor-0.2.4.tar.gz 5971 BLAKE2B 95be4af04df9ec9104872fa1a97dfe48174032f
DIST ansicolor-0.2.6.tar.gz 6224 BLAKE2B 38ffd0e9a88c886ebad25c4f0072f2f8f833e028c3bc14eb89252c1c0b501f973c9b3e371b4c605a3b98df33eb7203a963797d3ee56cf87b0afb927b19096fd5 SHA512 44c7dc6f621fc3044d4a52acb96e7e497578e025090633bfc8cbf686d7461da018f64502b477a6090e60747481f320cebaad00ee0776c9f4c52d4abbb1812121
EBUILD ansicolor-0.2.4.ebuild 578 BLAKE2B 6e992717a80c4f93407abf4c8d7382917207c0584b05671cba124e6ef679ffafcf3e2efaf5d512cdb76bec4134b2e4f1608630e34fa82b58072011a1768b318e SHA512 53a17a624ea5ac2c48b74edc46acb7fea0a4d681b346503f19bc5a8f2c9c86b594ecdf948598052620cbe8dda8e37ccd61f16aa2895e5b126198bc1589df415b
EBUILD ansicolor-0.2.6.ebuild 501 BLAKE2B 78e50adf8b370b8415acf61c1df077e488e5f8357ef8e4f40e37a4c361c00d669df0c85fa17a4faac976205ef585337a5e23218d22b291c34c9c4376bc6c40f0 SHA512 18cb27f2c194fbf5145ede06725bd55a9a758f70b7378b49994fb789ef841104e0c8dd7a04fbb238ccbaa36d73e479b6abe97a7ef739018e1574a147d3fc8c5d
+EBUILD ansicolor-9999.ebuild 608 BLAKE2B 38ceccdeaf128de5fae90cef958f90a386bc92e291d384597179be4e0cb621f4e14a19fb159d36a81394de1e93339cabdd0d867e9cf73112ca4fa1641291b79e SHA512 b96325013c261d84799d051827b28903e3db57c2d1542f0033a247ba2f88122a6ba7f8dc23fb45ce5139256557cf3b4abdd03376078891c84ec66cfe36241755
MISC metadata.xml 497 BLAKE2B ce249e4bcd8f3e7eacfbe1ce27ee5fc2746173417a81dc51ea3234632e436c256bb5be663d9a8e0a514378c084a6beffda8b30112d82be96c1f6d1748f78d8a7 SHA512 539ed7d24279e0c9a23166e4c2a19326c6bbeeebc17b5d55b0ebf45621005c47bb6cd7f434a30d93c585b7444b327f9e87389f0a63cdf000ea8e13ae23625400
diff --git a/dev-python/ansicolor/ansicolor-9999.ebuild b/dev-python/ansicolor/ansicolor-9999.ebuild
new file mode 100644
index 000000000000..bbb99ff83a32
--- /dev/null
+++ b/dev-python/ansicolor/ansicolor-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Produce ansi color output and colored highlighting and diffing"
+HOMEPAGE="https://github.com/numerodix/ansicolor"
+EGIT_REPO_URI="https://github.com/numerodix/ansicolor.git"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ py.test -v || die "Test suite failed with ${EPYTHON}"
+}