summaryrefslogtreecommitdiff
path: root/dev-python/ansible-compat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-01 09:04:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-01 09:04:22 +0000
commitd88834e7a12432c4e2d04ca7e938a66e25811f89 (patch)
tree9e31e0c72268908e8433ccfd6384a039525c1a32 /dev-python/ansible-compat
parent7414e061f0ef8e77eaa6de051a83181cddbef1dc (diff)
gentoo auto-resync : 01:02:2023 - 09:04:21
Diffstat (limited to 'dev-python/ansible-compat')
-rw-r--r--dev-python/ansible-compat/Manifest2
-rw-r--r--dev-python/ansible-compat/ansible-compat-3.0.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index d7accde16a12..1ab8f9c4ce2b 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1,3 +1,5 @@
DIST ansible-compat-2.2.7.tar.gz 47378 BLAKE2B 58f3b19400fb7646d37c585df07435e65a60f3e57d445c98e8089c6a2ed853cb5dbab682d85cee1a604e1b4de6dd137faa12bf78fe7913752839f95bd651435f SHA512 9a3863be3d755eb5a1a61ba0c526786ea3df14bc6fcabd9196559eb625ab6dfc8de7a17fdb2cdd8ad71d7d61b5e2f0543b8b5908f39d5e7d9ea45e387aa625b1
+DIST ansible-compat-3.0.0.tar.gz 62265 BLAKE2B 7a944fdf5fb419b95f9da0e28cc4e58f5a8fb969653bb74fa2a4103f7d367210bf86de95fa5f3493ef383db4d8ffcc2ab935c006450c2778cb10b256cd32c515 SHA512 af4e1de6b1c73f2c59ae6c7a209f401a9e7871b3674a06c1da48f00d1d508596c557f497cd07b2e32d09814de17c1bfbb0f208b4cef64b2a3457ec47aaed2824
EBUILD ansible-compat-2.2.7.ebuild 1676 BLAKE2B 29a6d0dbe1e9e443f8b2ba4481cc610cde37726ce71d6b7e021eafdf3f2f4ef95987c065695316d130f7387eec0bed4d5686077c5f5f8ebcedfebfc24162ed6f SHA512 9db031442edb5ee732337bc415c9ee8489c2eeca49544274c5b33dcde4bed95400f68885f981880f6495ceb5dd6e9843bd9951e5ff8e5d4c5beba75720c0762c
+EBUILD ansible-compat-3.0.0.ebuild 1555 BLAKE2B 840110ffe2e105270da8024a4d2c2080955acfad1321d6bda29d58f2a1072ea93bbe5802b9f71924a72ed3bd3b5248aef9b9683952581b8f34b84787fb974614 SHA512 0a439f190bd41d2a019a7bab7a3a2cdc5609c3c80f08a569bba7042f04843d13c48261aea6586bb401cc037876938e161ca21eb92848ab38c8fdda31afb89adc
MISC metadata.xml 510 BLAKE2B 3f47270866cb9acc5944b71547640b69003891268ffc07b5cd10e6ba8842b6f644ab4dea3b3da2d20b17f34d90e565b6f03a4dbb8ea38fa282fed283ac22fac1 SHA512 65d8604e46581bf9ecb3d8e358f3a211b18c51beea22c92a1cd3668ba86140e3bd8d91a38c221e73fe13a3e0da1cbfc2030b3f7733ee55e045530b49cd77d46d
diff --git a/dev-python/ansible-compat/ansible-compat-3.0.0.ebuild b/dev-python/ansible-compat/ansible-compat-3.0.0.ebuild
new file mode 100644
index 000000000000..c1d94be9be9e
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-3.0.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.4.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-7.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+)
+
+distutils_enable_tests pytest