summaryrefslogtreecommitdiff
path: root/dev-python/ansible-compat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-31 21:06:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-10-31 21:06:00 +0000
commitc9c609463fab9bcfb35694627bca1429a21fdbb2 (patch)
tree024860c3c54aa33cdb6972acd3e2e0b8484f3aa7 /dev-python/ansible-compat
parent6dd9db91dd6ce9bbe3197aa82642866e637ba68d (diff)
gentoo auto-resync : 31:10:2022 - 21:05:59
Diffstat (limited to 'dev-python/ansible-compat')
-rw-r--r--dev-python/ansible-compat/Manifest2
-rw-r--r--dev-python/ansible-compat/ansible-compat-2.2.3.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index 3950f13f3aa2..7c4e03c56a8b 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1,5 +1,7 @@
DIST ansible-compat-2.2.0.tar.gz 38772 BLAKE2B dbe74d23d2f2e4275bd9df2303417ea83517e780e65c6a34bd6ae1022be265ac816b50b309fc45f88e0c7fac7d7a22c83a826cc15be050698a6f35b267a36ac3 SHA512 3bd199431659ecba52743c6c985d2cdc6ee55396444241ba2456bc5430bbc87e26087dffbfff62ac341fa854e19baa0d7052cf79f20511222fd9e001dd020136
DIST ansible-compat-2.2.1.tar.gz 39126 BLAKE2B c4d0512606c99ba8f07e0287620c94af6b46d7bf0077f12dcbfd9689fc7106f164a87db25de1625249ac2930858bfa655bd93d83aba0d85ed4f8bdd42cd345dc SHA512 3e941eb2c5303f83b7e7c057d08801f192889b636d9c6e56a2ac21cf75144a52ba2916eaedeba7bf848dd268387bf4d3261541d75145b213cc3f6baca6a06e5e
+DIST ansible-compat-2.2.3.tar.gz 39603 BLAKE2B 16b88a1c669a74d858e4d47539811b33db77561f7e72088d5eece67ee1594e65a9328277bc65b96dce726180c29118b2b240b45541b6548b34584d643f836894 SHA512 4944ff97524734c445438c052aeedd0d526b58e91a56e0bcc32123fb3a9464c82f7718ea1897a09ef0dd33dfa36abdc6e0a0157e9a4eb8d341cbd712b2f538d1
EBUILD ansible-compat-2.2.0.ebuild 1840 BLAKE2B 11d1bc410ec521216457cfe2bbf90a26a67856d37415eba2f3c3ad7e303f617c60337f1aa8e27b5b74b0cd9e3a49a8f65c4778582cfb6941454ae7f6a3dc2a6c SHA512 70efd21b73ba994b081b73250b81b085b1de99c310b43875aae9ea403818efbda90a1364bcadd770371bf1e3ba28ab2664641d5cb103f1cf849f56828c9e3733
EBUILD ansible-compat-2.2.1.ebuild 1841 BLAKE2B 904c48ad161c04d567bcbcda9595c9a477645fc2e142611227719e11a8df77aa5a2715bb8fdc1a01013941759baad984f923e49a66a0c831b046a9abab9c0cbe SHA512 7d77e77637814d7df743ca402e38a2815526dfc629e46653283d9f804cf688f699e13a06df2cf4c10b345ec9b5631aafbed9673d402315caa90f6a007ce69803
+EBUILD ansible-compat-2.2.3.ebuild 1841 BLAKE2B 904c48ad161c04d567bcbcda9595c9a477645fc2e142611227719e11a8df77aa5a2715bb8fdc1a01013941759baad984f923e49a66a0c831b046a9abab9c0cbe SHA512 7d77e77637814d7df743ca402e38a2815526dfc629e46653283d9f804cf688f699e13a06df2cf4c10b345ec9b5631aafbed9673d402315caa90f6a007ce69803
MISC metadata.xml 510 BLAKE2B 3f47270866cb9acc5944b71547640b69003891268ffc07b5cd10e6ba8842b6f644ab4dea3b3da2d20b17f34d90e565b6f03a4dbb8ea38fa282fed283ac22fac1 SHA512 65d8604e46581bf9ecb3d8e358f3a211b18c51beea22c92a1cd3668ba86140e3bd8d91a38c221e73fe13a3e0da1cbfc2030b3f7733ee55e045530b49cd77d46d
diff --git a/dev-python/ansible-compat/ansible-compat-2.2.3.ebuild b/dev-python/ansible-compat/ansible-compat-2.2.3.ebuild
new file mode 100644
index 000000000000..0a8b7add6886
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-2.2.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.3.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-6.3.1[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-markdown[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+)
+
+distutils_enable_sphinx docs \
+ dev-python/ansible-pygments \
+ dev-python/myst_parser \
+ dev-python/sphinx_ansible_theme
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p pytest_markdown.plugin
+}