summaryrefslogtreecommitdiff
path: root/dev-python/ansible-compat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-10 12:30:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-10 12:30:41 +0100
commitadd278b9601ff9e4af091c91c851ee46a185be8f (patch)
tree4b654beae0eec584ae1d1f3227a57607d591a0ea /dev-python/ansible-compat
parentd8a7472fc6314625f7d16e0427004eb448412908 (diff)
gentoo auto-resync : 10:09:2024 - 12:30:41
Diffstat (limited to 'dev-python/ansible-compat')
-rw-r--r--dev-python/ansible-compat/Manifest2
-rw-r--r--dev-python/ansible-compat/ansible-compat-24.9.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index 50d5db322097..961a5f17af45 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1,3 +1,5 @@
DIST ansible-compat-24.8.0.gh.tar.gz 74341 BLAKE2B ce6edf8ed532815f2e307ac51eef0ac694805b0d5f8cad78c75c57478a21eb443348d636ca0e405fe63d32daf0f426c20e0f97183082f0eba3dd4b889fb8be80 SHA512 07da3a5d4f6eaa6edec3a03107d6e751e9754a84420a9839239d17811de01e8c70bed84e8c23a1308d18e8388581b0e269ae03c235bbc244e95a29c3be25567b
+DIST ansible-compat-24.9.0.gh.tar.gz 75290 BLAKE2B 0482d9eba967d4d846e35f3a2754410e1f42d34e451b2cf42bcbb88155fdf90859b9fbf6ead28a6e8c252d3a37522c1d1c903a38d4e47ba427678bc39d3c8e9c SHA512 e6803e598fabb1097bf0f10a7b9592af97152d108bc89a29547546de0eaa87ebba9232e78aeababb3ffd94c58af8b93499de9c059a6c42d04179d02b50d92a0f
EBUILD ansible-compat-24.8.0.ebuild 1818 BLAKE2B ace93c01b61d04a32c33ccc7450cb9ceb2be8009cc5e7baa4117af835bd4bcc1aed460bd25b8e077a65ecc6a90214f00fc97aa2aaed5b8a218f273454bcb7fad SHA512 84d1934eb613ead748591fe870356122258fc328e1b5fabda2472697e3ca72655e07f31738c8e7ade5d0738ae6b8ad6c8e65d00b9822f6740bcbc188481d72e2
+EBUILD ansible-compat-24.9.0.ebuild 1819 BLAKE2B 45f593be905c5424d724e507998528cf9b194372c497270a3dfd0fa8fe3404a6c6d01fa7c928b1aeabdc08e0ac2d4053657ec2c7e46b3b7632300d80f74dab6b SHA512 0cf744412ffcd8ac2e7446cff02f00ca5a3c91194b2e601456b2a5941391dc36a7903224cd35a9ba1580012ad04f72764bb56375fbe30e061a42bd0396f28add
MISC metadata.xml 404 BLAKE2B cd6a8ae349cbfd750d8e439a93902221cce72c0c03280ef1e99514981f6a1079bf9e16a9eaf58ad1758e83a82625b508ccf461ff487ddf8c378cdf7fd46260f8 SHA512 15330e4ae03c21f1db7a42cd9efca50a2fe60b828caef1dbb29901f39f4089d6b3a3c593ca2bd01c7873c8ff12b15227d0c8ae09450271d733cc36ff979b3365
diff --git a/dev-python/ansible-compat/ansible-compat-24.9.0.ebuild b/dev-python/ansible-compat/ansible-compat-24.9.0.ebuild
new file mode 100644
index 000000000000..18c39cfc27c2
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-24.9.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+# We normally use PyPI here but 4.1.12 has never been uploaded there for some reason
+SRC_URI="https://github.com/ansible/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.14[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.4.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+ # pip, failing due to internets
+ test/test_runtime_scan_path.py::test_scan_sys_path
+ # internets?
+ test/test_runtime.py::test_runtime_has_playbook
+)
+
+distutils_enable_tests pytest