summaryrefslogtreecommitdiff
path: root/dev-python/ansible-compat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/ansible-compat
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/ansible-compat')
-rw-r--r--dev-python/ansible-compat/Manifest2
-rw-r--r--dev-python/ansible-compat/ansible-compat-2.0.3.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index f7c5d50e2cce..9f0f9ae7e648 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1,3 +1,5 @@
DIST ansible-compat-2.0.2.tar.gz 35072 BLAKE2B 288baaa4bb535da5fc41ea6a700d4eaf969b466848a592f3c919cac55b237cc81b9bfcd800a429b89c82781b29e80dc6486ea9bf0621ae8a3f249139021030e2 SHA512 ae278498f58ac1eb663115215e7ef6bda7279ff02d4a1f09e8301b88681d8c46f13a620b765cbbbacfc3d1fe8b294d5258cddbf7fd2f2cb54f0bde85fc9af593
+DIST ansible-compat-2.0.3.tar.gz 35328 BLAKE2B cd5a476eb23de667381c9a6667d6bd781821fc50e1aec65ca47e8bb9d47beccbea0ee62f763ed421c18c95d9f1d1c14f5cc2a62bcc77d664213eb614ccd568e4 SHA512 0887e5da23041d02be0371bfd9569256252c586f80cd92ab855b32172328989c8160e57169aff6d72f1c3c89c9d3a00b56293e3badc0dc4aad135b1992d06599
EBUILD ansible-compat-2.0.2.ebuild 1702 BLAKE2B 425593284f3679798c96fabae8b20f2307664b5b216dfde1513c3b5c0a64e24137d62278c90de17e79ed63d1a525d31b60144145abede9e0b93a2f20db39bb9c SHA512 676c9c05e3aa8726712159d66476b1170b96e21b87db102e9ed17f939dab9879b55d192935fb7bd4e814a286395470d0da258a86bbf6df47a0ff5d341ee56572
+EBUILD ansible-compat-2.0.3.ebuild 1752 BLAKE2B 0cd874164f298c45b39041a23c5b1de34398473eebd168cb48af5efcf777b4bf22c7afac88fed59d36d71c0ae3125df4de4f7aa32dd31c4360a10c6ca5540721 SHA512 0c9128bc5a377bf278b07981ee4404393e7164f1a1621d5f75b566f5b08ae8e189f276a21d146d306686727fba090455df37360c36ef4d82c8f18a125830a061
MISC metadata.xml 409 BLAKE2B 60c2a2a8a80326a6fa9b375b3bdac4f8f609d071f5f06f76a0a80038bf9950c7c2cc377ae883abab3d93104fe2095a8c31c2bc3554b97f5e9e4a2cef8a8cec72 SHA512 900ba03ec907dcbba53f4eb6827485c5948300e04d7b00f9159d328f8bc507a5bc9f893593f0dcc7029b5f6c480a1129ddb541f9ddb40e3b389669bfb0d1f3f1
diff --git a/dev-python/ansible-compat/ansible-compat-2.0.3.ebuild b/dev-python/ansible-compat/ansible-compat-2.0.3.ebuild
new file mode 100644
index 000000000000..5b3828e761ae
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-2.0.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-base-2.9.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.3.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-6.3.1[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-markdown[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+)
+
+distutils_enable_sphinx docs \
+ dev-python/ansible-pygments \
+ dev-python/myst_parser \
+ dev-python/sphinx_ansible_theme
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p pytest_markdown.plugin
+}