summaryrefslogtreecommitdiff
path: root/dev-python/ansible-compat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-02 17:45:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-02 17:45:32 +0000
commit5939313f229e6fcf374fb7e9ee4f8675b05ab293 (patch)
tree0a8181cbc5d052ab4d26a8e1d2dc52f126063fc6 /dev-python/ansible-compat
parent7e3d6dcede5749fe6a1adef4e673a9dde7703b7b (diff)
gentoo auto-resync : 02:02:2024 - 17:45:32
Diffstat (limited to 'dev-python/ansible-compat')
-rw-r--r--dev-python/ansible-compat/Manifest2
-rw-r--r--dev-python/ansible-compat/ansible-compat-4.1.11.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index 9b02699dc31c..65ff8bfe5b56 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1,3 +1,5 @@
DIST ansible-compat-4.1.10.tar.gz 72127 BLAKE2B 1a3c172d30a68f14a163d2ad04180856d365424b99c593933c02c83afde7008f937a86f068fd4d09741eda731a0ae9801274764e349f56fd4a64ccdf1ff831b7 SHA512 f50d07d753fa2f3985efca4aa326d3608d55b3f8d00c42c3bd9ba95c6e40c7a717160220dd602374124ebbfc94c495819b4b738cb385875033876aee458d14b4
+DIST ansible-compat-4.1.11.tar.gz 73021 BLAKE2B 4d62c6c6739ae5dcfe98347eac268f6976f12cabcf8706f89ebaed2a6750a47faaf53ce5585ee2d6a2cf8a92add9f8f74bd050e44fa6f5515a9b77a7f49979c5 SHA512 0e8de16ef0da9a036595dadbdfa5fd776f8edf0d2c16e8e2759a0e1b07f0d0fffc22a8c7be17aefb73312f3c8f56d48fdf097c527fa3b8919907923fffc44fa7
EBUILD ansible-compat-4.1.10.ebuild 1619 BLAKE2B 3dd6e3a5a5241f9eba9bedee17b556950e74aada37fc550984db97b94df169c294003b56f0eeae7a98288f8f7e9b707645d4eb3d912b5e5ccc5a8a396760f04a SHA512 9b7995b32a34d12f194b6ca0ddf91a96afa172f191fff4687490496b68a638e3d8bc95d5e1b448c07ce7ac4d677a5b3a3464c14e0f1b80e296bba2c75decbc64
+EBUILD ansible-compat-4.1.11.ebuild 1620 BLAKE2B 753dc8d96eac8e507b5e11e7e4ff9c57fd6d9ba97e10523a86048d994d3bd3a1a7ea33b7ce935c2215739672dee1731211161c655d19b4b7f9a21a8f9bd8bb93 SHA512 84a7aeb71f08b19f627fb84384c6b562f29b53e0289ba1995cfb9830effc31960e843afb69b8a5ca220fc1d0bba6910bf7e82d1aa05e32886201ac24084c8503
MISC metadata.xml 510 BLAKE2B 3f47270866cb9acc5944b71547640b69003891268ffc07b5cd10e6ba8842b6f644ab4dea3b3da2d20b17f34d90e565b6f03a4dbb8ea38fa282fed283ac22fac1 SHA512 65d8604e46581bf9ecb3d8e358f3a211b18c51beea22c92a1cd3668ba86140e3bd8d91a38c221e73fe13a3e0da1cbfc2030b3f7733ee55e045530b49cd77d46d
diff --git a/dev-python/ansible-compat/ansible-compat-4.1.11.ebuild b/dev-python/ansible-compat/ansible-compat-4.1.11.ebuild
new file mode 100644
index 000000000000..af5646e9b07f
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-4.1.11.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.4.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+ # pip, failing due to internets
+ test/test_runtime_scan_path.py::test_scan_sys_path
+)
+
+distutils_enable_tests pytest