summaryrefslogtreecommitdiff
path: root/dev-python/ansible-compat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/ansible-compat
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/ansible-compat')
-rw-r--r--dev-python/ansible-compat/Manifest3
-rw-r--r--dev-python/ansible-compat/ansible-compat-0.5.0.ebuild53
-rw-r--r--dev-python/ansible-compat/metadata.xml13
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
new file mode 100644
index 000000000000..5518bfc81141
--- /dev/null
+++ b/dev-python/ansible-compat/Manifest
@@ -0,0 +1,3 @@
+DIST ansible-compat-0.5.0.tar.gz 32913 BLAKE2B 468dbcf20865225c76896dd8aad6f4b9a749b7a45d661484f89e2eaab4416b29f2e0ea0477b86ea52193165cd23180a79ebd5adac571e0b7d659096e84c27bcb SHA512 3ea219ceda313daf923d11ff45c31a760ddbae7ac782b1f89316eb29960a8028fab4e7e242fa0247c6ef5824d71ff9f22ae8956af73dda261a69713110e3db8e
+EBUILD ansible-compat-0.5.0.ebuild 1833 BLAKE2B 68adb5e57ae000f40f04d0951abd8553d210cb224d192b0943c23c9b7610d9adf635ab6bca04c62fb820edfad20e26398905e814ff979cc84f447c245905aa32 SHA512 cba48e8ae2b0b49d2cb03a67deb7d7ff5ad06422ab4aa1917f20810c2266292d790261697846a4833b3c2abb6764d13c262e0d6b497da874046073cdc04b97fc
+MISC metadata.xml 419 BLAKE2B 5862d98909b54bbf69b84b10742ae5c4e8e5919f84a986161f8fb948f472c9f4f8b567fd4fa81d259395187c8b58ce64c2675349b076d9087021c2ef246d03d9 SHA512 9c22801a3c01f6d1be465823f3b78ee43016dd037ce80f99f78ec0d906fef887260b830ff20d523fae085204914cecece77893e3c3a7c5a6247f301395d8e3f0
diff --git a/dev-python/ansible-compat/ansible-compat-0.5.0.ebuild b/dev-python/ansible-compat/ansible-compat-0.5.0.ebuild
new file mode 100644
index 000000000000..7b7537c2f7bc
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-0.5.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# TODO: 0.6.0+ support py3.10 upstream but as of 2021-11-18 we are still missing
+# support for it in app-admin/ansible-base, add when ready
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="https://pypi.org/project/ansible-compat/ https://github.com/ansible-community/ansible-compat/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=app-admin/ansible-base-2.9.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.3.5[${PYTHON_USEDEP}]
+"
+BDEPEND="$(python_gen_cond_dep '
+ >=dev-python/setuptools_scm-6.3.1[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-markdown[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+')"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+)
+
+# Requires currently unpackaged Sphinx extension myst_parser
+#distutils_enable_sphinx docs 'dev-python/sphinx_ansible_theme'
+
+distutils_enable_tests pytest
diff --git a/dev-python/ansible-compat/metadata.xml b/dev-python/ansible-compat/metadata.xml
new file mode 100644
index 000000000000..d3c8f1c3e37f
--- /dev/null
+++ b/dev-python/ansible-compat/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">ansible-compat</remote-id>
+ <remote-id type="github">ansible-community/ansible-compat</remote-id>
+ </upstream>
+</pkgmetadata>