summaryrefslogtreecommitdiff
path: root/dev-python/ansible-compat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-31 16:11:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-31 16:11:27 +0100
commit260722f712fe06c113e7b13ad2e924ed14aaf0c4 (patch)
treea29845500e555a40458a70b7ed2896588134df2a /dev-python/ansible-compat
parent0fde6d7108b1ee9fc6ad186eff4978faa255db20 (diff)
gentoo auto-resync : 31:08:2023 - 16:11:26
Diffstat (limited to 'dev-python/ansible-compat')
-rw-r--r--dev-python/ansible-compat/Manifest2
-rw-r--r--dev-python/ansible-compat/ansible-compat-4.1.8.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index b7e47939665e..193d1bfb8e74 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1,5 +1,7 @@
DIST ansible-compat-4.1.5.tar.gz 68562 BLAKE2B b28b6e5185b29a55d452e9c72636b31a1a35c68f207cc07376fafd0a70335966d06f927a803582b715b29c090a80aa5aa2663cba54221cb4d2dbcd9a11ec5a7a SHA512 6da0bab56237a6447462ed9ef528711eb4c998de2732ec021e8257d2baf6cbb1e1435707440b4c0d122fb4f938c855693bcd555e147613f230105e3af74c00a6
DIST ansible-compat-4.1.7.tar.gz 69900 BLAKE2B c8549573d4a4325579b6026b6b5fad5fe0abb0fdcf07a4c8e0699c040a97409632202f0a38703a113f9a86f68328642d8d5c4b897e3601a13737bc2a4deb4d88 SHA512 b3175573113a3df37923e582c191dd5f4522c3a2171cc93b186e49d5ca6baa2fd8b2e7af2e9457bb21b5bd6df6c9f82fccc10b5e2bfeda84c890c4cbc37fafb4
+DIST ansible-compat-4.1.8.tar.gz 71895 BLAKE2B 19a3cdc953e678a82f6b187ca224c9f10eccf36f57aba2305bf00bc7b3606dfc2caddef7331cd920ae67731b904bc21b1af19fb0945625b050162e0edc8ab652 SHA512 0b9157fd60e1ae9b26c103118fad3e8e28f872c7093d0c6238b047072ac3232e7f9a4c50001125850f4bdd0ba06a1efd8df44a994b1dfaaf7d3f3cb2cb888524
EBUILD ansible-compat-4.1.5.ebuild 1527 BLAKE2B a0f1e3760eb39c5f93aa65d3f3bf11496cbfdfff9e0a269f156ac3c62bee4a2b655cf23e1fd73e658fd3c488d1c487b76cd53cc666b1eefade2a699b39862cb6 SHA512 ac5f475f95a4c9df1a6d57ef2045254f5ad99e2a3f6dbd9cfc5fcac4f65b0e1519cf6531cc2851aa90074cf10d321596030a0585410323f3a1e6c54367d56b4c
EBUILD ansible-compat-4.1.7.ebuild 1528 BLAKE2B 6cfa80b2ad48686524e0709e6407d9cb2c4fba7e9ff813f75ebb2a74e37968b6a5078c411b54325950741ea2674e159a264175b92a255db544985985bf27bedc SHA512 bceccbf47fd58b40f00baecb358e55dee173d28ef21f8245c1d281674243c3e8ebca13a655321827d73a0c60e494992aace3f53129263b9d1713f482221e570b
+EBUILD ansible-compat-4.1.8.ebuild 1613 BLAKE2B d3359b099f7f2b6b358b741c257f0f64b66b46428110b6234a4e4525f7193edf9b55d9886ab4374ed9cd0b7dfabd5f35457801bd6b94f85fcbf4bd2135c147d8 SHA512 3bb568c1335db812c4ef09cdf191712e33309d9baf940dc89cf74bdcdcf402f9f7dc72fcb1ae2276852f2a96d0af8c905fe9c45f28c5707edcb565a6377768db
MISC metadata.xml 510 BLAKE2B 3f47270866cb9acc5944b71547640b69003891268ffc07b5cd10e6ba8842b6f644ab4dea3b3da2d20b17f34d90e565b6f03a4dbb8ea38fa282fed283ac22fac1 SHA512 65d8604e46581bf9ecb3d8e358f3a211b18c51beea22c92a1cd3668ba86140e3bd8d91a38c221e73fe13a3e0da1cbfc2030b3f7733ee55e045530b49cd77d46d
diff --git a/dev-python/ansible-compat/ansible-compat-4.1.8.ebuild b/dev-python/ansible-compat/ansible-compat-4.1.8.ebuild
new file mode 100644
index 000000000000..6a1d0e51abeb
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-4.1.8.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.4.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+ # pip, failing due to internets
+ test/test_runtime_scan_path.py::test_scan_sys_path
+)
+
+distutils_enable_tests pytest