summaryrefslogtreecommitdiff
path: root/dev-python/ansi2html
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/ansi2html
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/ansi2html')
-rw-r--r--dev-python/ansi2html/Manifest1
-rw-r--r--dev-python/ansi2html/ansi2html-1.5.2-r1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/ansi2html/Manifest b/dev-python/ansi2html/Manifest
index 0d6b0c46abb3..dae36ba7f96c 100644
--- a/dev-python/ansi2html/Manifest
+++ b/dev-python/ansi2html/Manifest
@@ -3,5 +3,6 @@ DIST ansi2html-1.5.1.tar.gz 27133 BLAKE2B 8a8017b8f4edb878b105138ec0dfe3fbde8647
DIST ansi2html-1.5.2.tar.gz 27124 BLAKE2B 0d02e8cea46622c4d2cbd06f06fd31b3c7e93d61f6b9eadb37815d2ee490b6ce4233fb019f175f61465ef89520a944bbe14543627a6421a64304b58dc038c0ca SHA512 163d5784d04e6eea0847676b967051382fa74a354c19462d1b73980fd1b0a7eb45ce1f1bd88cca803356e7767ccab1bbce6de4152c98aec98534f4ed7d65a83f
EBUILD ansi2html-1.4.2.ebuild 990 BLAKE2B 75f05088a27bac4cbde392e8750bf5679197896700d5e60dba0b091f3a59503c059f8e080e554ed367aff10f7ddfd250fce5eca3416a1d056bf818ae3d218a43 SHA512 86c192c6018b4c4cac06c311aec8f962e84b3c1464581e356fcb8f81244ee5d4b645b2854abaa4fec4f266eb10a463f9a87608a44857068ef7cce3ca816143c3
EBUILD ansi2html-1.5.1.ebuild 911 BLAKE2B b434211c7419242d6dcdffefedb7b6d303c8535767579080d7bf24d5847e4d1690a3254396545dade23991f16a018e5325db85ab89c2a3ff285472de6a85cffa SHA512 fe38cf1303b2ca9701672dce5c9824c13d80e463c2958cbd4ed087b0ec4a3cf4128c145cb1e6bd1bc84aa52d6060efb9b430aeba38bb6bc78eef57a7f87bf747
+EBUILD ansi2html-1.5.2-r1.ebuild 898 BLAKE2B e61534ac600f311229394c6569f657d96949283edf516403439c8739fb9fe06ad261bf1b739be2788473a5f68731a458141d5709446987a406009863523ee87c SHA512 2e2163f62dc4dd34facec9b4f8c17f729365bcb0fd65048c36e061460d04c478bb8b4b7cc061e910211af535deda2cc7a88887fd364ab9fc832eea22281b6a68
EBUILD ansi2html-1.5.2.ebuild 908 BLAKE2B 58494bcbe4a8f1241fe58e3f441bd33ef15ca1421b8117942415ca652e8502da19f91503825ea3421634b4dd594535682f573828af8a11b947126dca165a97b6 SHA512 714bae01fae939e04b13b98bf3f2c23d3bbd25e15810d6966b6a91bd29aa6a2bf6b8b93e021c4dcd745c972dbdcac6d505fec999e97eaa7432fb5c843df838e6
MISC metadata.xml 392 BLAKE2B 13621595cc083a069522c51b4e29b362f7217698c194d5247d73a3acdaca7ca8b13a3afb0e9b0671785ce246219d44bd8511c5ef243111d43067b138635f5963 SHA512 a17684f5bd76762a832cba99a1edcd2b2ebb1abdd27f36528fb4d2ded639b6223f60495c6dd2ee548826f3a2e177238318c02962d2300ace37eaa881e76cf095
diff --git a/dev-python/ansi2html/ansi2html-1.5.2-r1.ebuild b/dev-python/ansi2html/ansi2html-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..68135b1df10a
--- /dev/null
+++ b/dev-python/ansi2html/ansi2html-1.5.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Convert text with ANSI color codes to HTML"
+HOMEPAGE="https://pypi.org/project/ansi2html/ https://github.com/ralphbean/ansi2html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ "
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ chmod -x "${S}"/tests/* || die
+ esetup.py check
+ esetup.py test
+}
+
+python_install_all() {
+ doman man/${PN}.1
+ DOCS=( README.rst man/${PN}.1.txt )
+ distutils-r1_python_install_all
+}