summaryrefslogtreecommitdiff
path: root/dev-python/ansi2html
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-05 16:14:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-05 16:14:04 +0000
commite65ee315554600740a3ecc9dde351e7ded136023 (patch)
tree3073404df9dc37dec78df9d7ddc289568089bf77 /dev-python/ansi2html
parent68883bef20f77c2d72dfdf20bf5f9d4a5ea5ad9c (diff)
gentoo auto-resync : 05:11:2023 - 16:14:03
Diffstat (limited to 'dev-python/ansi2html')
-rw-r--r--dev-python/ansi2html/Manifest1
-rw-r--r--dev-python/ansi2html/ansi2html-1.8.0-r2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/ansi2html/Manifest b/dev-python/ansi2html/Manifest
index b560709af522..f36ea4657271 100644
--- a/dev-python/ansi2html/Manifest
+++ b/dev-python/ansi2html/Manifest
@@ -1,3 +1,4 @@
DIST ansi2html-1.8.0.tar.gz 44146 BLAKE2B 66672927a64ad38dce0b0819fabc3778f6aba82d176e992630a8db076988a21af8dd445306b8bb580f1539b35044b95de749d6bfb65c27f9b431e4cb6bd562c7 SHA512 cbdda41f206ced5b19761a1ff9747acc6cadca3a5a2f58c97c6073db7d517e59fea7601bba28a8e7e105f3c0c9c4d78ca4f242100cbded6c8a9ca2d598de0ab4
EBUILD ansi2html-1.8.0-r1.ebuild 695 BLAKE2B 2d63a31f63948d5aea7f83dc1d0b08e9343c839ec81da50051133fb310f5ca6d8cb16da28929846f55bc0ae9d05ef4d1591f97033edf45dbd40e51ff9ab3631c SHA512 1adda22389191673da53d1d79ed9433dbde3e8e4225522db763de47d489d8230d71b635906e909588e6c070e8226bf5ef59d15546b972b0fa7d6a4f7192ed14f
+EBUILD ansi2html-1.8.0-r2.ebuild 633 BLAKE2B a56c7be9522e92b59a66cb61e18fbe252e3da8dd7420e7a861897ae2b42af7eed845b1d67d7273d45b6a598abccc17c6f35886b9f564a62b6d42b96333d323ba SHA512 3fcc93dcf2bb43a77dfde826410ac085b102a9968de072577b704ef672cb1c8b7e8be82a930c0c95e9c4f28357d6f06dce0a106330ca3059dd22846eeffcc7ae
MISC metadata.xml 406 BLAKE2B af6335def83547635dc916a45f1d9296faa0e1806237eeb76deac4ea28e701549bdc7fc9cab7e35b84e8f5c32e31ac7bb22c924865872326b70485acef36d517 SHA512 ebbf8d50e3c798cd2889bec1f5bd3f827bbedb9bafe4610b88fa18b1805514f156351786461ae558769f1ce299174d50ee06c864e008d013b26a6c1afb10792e
diff --git a/dev-python/ansi2html/ansi2html-1.8.0-r2.ebuild b/dev-python/ansi2html/ansi2html-1.8.0-r2.ebuild
new file mode 100644
index 000000000000..6cddd195fb25
--- /dev/null
+++ b/dev-python/ansi2html/ansi2html-1.8.0-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Convert text with ANSI color codes to HTML"
+HOMEPAGE="https://pypi.org/project/ansi2html/
+ https://github.com/pycontribs/ansi2html"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+
+RDEPEND=">=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ doman man/${PN}.1
+ distutils-r1_python_install_all
+}