summaryrefslogtreecommitdiff
path: root/dev-python/ansi2html
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/ansi2html
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/ansi2html')
-rw-r--r--dev-python/ansi2html/Manifest1
-rw-r--r--dev-python/ansi2html/ansi2html-1.5.2-r2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/ansi2html/Manifest b/dev-python/ansi2html/Manifest
index 4078411960cd..82f63c3b0802 100644
--- a/dev-python/ansi2html/Manifest
+++ b/dev-python/ansi2html/Manifest
@@ -1,3 +1,4 @@
DIST ansi2html-1.5.2.tar.gz 27124 BLAKE2B 0d02e8cea46622c4d2cbd06f06fd31b3c7e93d61f6b9eadb37815d2ee490b6ce4233fb019f175f61465ef89520a944bbe14543627a6421a64304b58dc038c0ca SHA512 163d5784d04e6eea0847676b967051382fa74a354c19462d1b73980fd1b0a7eb45ce1f1bd88cca803356e7767ccab1bbce6de4152c98aec98534f4ed7d65a83f
EBUILD ansi2html-1.5.2-r1.ebuild 895 BLAKE2B e6dfb3970f37f8219e7ef910d8b06bbda4b407405ff1f0341201522e37b328fbfed0d1b4bfb1562c85cbfc32339ed1a17f0671a38761c2589be8b47f4103b8f9 SHA512 3e315f50ff68bce0ece556af6b5089a3eabd53df323cd61afd8becf060539ca6cc20640ae81f3af4fd63003f7ddc2efab23e00bca5028c314dba74c708215879
+EBUILD ansi2html-1.5.2-r2.ebuild 715 BLAKE2B b1d23886870004271f835579114cfe0185a12f8a6365928a53b01e8510b868df20444e311c1701c509ead3201f29142337a5ab547c7a8fdabbf76895ab1eee27 SHA512 8679e25a833119a71cd68ec1a8bfd457ca0df20a2e0f5b64e9de6127222b3798ee453b9fd6b8de385adac55434d9dad59ebb5d7cf10f161eb63e963700dcee84
MISC metadata.xml 392 BLAKE2B 13621595cc083a069522c51b4e29b362f7217698c194d5247d73a3acdaca7ca8b13a3afb0e9b0671785ce246219d44bd8511c5ef243111d43067b138635f5963 SHA512 a17684f5bd76762a832cba99a1edcd2b2ebb1abdd27f36528fb4d2ded639b6223f60495c6dd2ee548826f3a2e177238318c02962d2300ace37eaa881e76cf095
diff --git a/dev-python/ansi2html/ansi2html-1.5.2-r2.ebuild b/dev-python/ansi2html/ansi2html-1.5.2-r2.ebuild
new file mode 100644
index 000000000000..6bcbcf7230e1
--- /dev/null
+++ b/dev-python/ansi2html/ansi2html-1.5.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Convert text with ANSI color codes to HTML"
+HOMEPAGE="https://pypi.org/project/ansi2html/ https://github.com/ralphbean/ansi2html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND=">=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ doman man/${PN}.1
+ distutils-r1_python_install_all
+}