summaryrefslogtreecommitdiff
path: root/dev-python/ansi2html
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
commit02e2208f46f4e2c00fb9743cbc47350bdd233bfa (patch)
tree132dd60828854db4f65f30f9230f43d9602507ff /dev-python/ansi2html
parent8be70107efbb417f839292165ee39d07a062046f (diff)
gentoo resync : 16.01.2018
Diffstat (limited to 'dev-python/ansi2html')
-rw-r--r--dev-python/ansi2html/Manifest2
-rw-r--r--dev-python/ansi2html/ansi2html-1.3.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/ansi2html/Manifest b/dev-python/ansi2html/Manifest
index a647aef8aaa2..678c198a279a 100644
--- a/dev-python/ansi2html/Manifest
+++ b/dev-python/ansi2html/Manifest
@@ -1,5 +1,7 @@
DIST ansi2html-1.1.1.tar.gz 46591 BLAKE2B e2eb3d9b2665fd495ee8591a3cbfebcd1d565edec9f8ec6840bed8303bbc094e71b9371f496f5f479da9d61937fb2e4ac4deb485631c2576bed33bfee731fba5 SHA512 5f08e6e3e89797f23759da7aac8cbd17e86ffcac37af8db8c345423c69744d88a1517cb0f17dc9c366b509b972484d25877cce8c7466a7a463eea24af17133de
DIST ansi2html-1.2.0.tar.gz 46748 BLAKE2B c5ea7d35640f93562f6098a46dbeff9248e25b6210bfa5e71265d529599eea7713581ef986faa5afefb445492fe09d2170d164a63b2a602c57a79f2c72cbe118 SHA512 3106488da19cd093d7ae2a7499a66baf77877f47da0e497791cea2a63079c184f1d36743e78116b3faf08ab145ca97b5774151114b9ca193020578c8a3bdc860
+DIST ansi2html-1.3.0.tar.gz 35989 BLAKE2B b2f949e2c559b2da91d3095b4d8ac2091bd15aad46b178a01aa59d4c900917e733f6ab3884d9c4c7c46bfa530936339d9b105a0471a09eb7a01693c43e8a87dd SHA512 73d1b3431e22146c4fe18fef4b05413231d79d627c396d67528d0aa1ab07a7ef4bcfeff56829b85d9fe9ad508599b782318911f7b10d6b9a1bc98780e31389d7
EBUILD ansi2html-1.1.1.ebuild 977 BLAKE2B 55799e5d290f30c6e9e10f10af4d990600b1ead2e63b8bac84b5be5fd75ca08938fcf1229c04647ddde2447db1e9f016f04ed5fea617be740afbfa314af2f818 SHA512 8c19c40da749aa75813b08e479fc316baa63a21d86068094f9f0397872e485348a8c9e252583abb789a8d9de8576870e41f98e4d5e9bbb6dc795bd734402068a
EBUILD ansi2html-1.2.0.ebuild 977 BLAKE2B 2cdb3a473a4a2a8bd350425edba570f95b9efad7cb085deeafdb3e65bc4a66085864e97b3f3cad267c0cfe5e60d974b21abf77e6a7bcfeb03dd6e7a77249ec3e SHA512 f12ce0f4fb159bcf287d085c99f4f3387c8e667c90faeab5d6a4036191c5aa98fbca498c64e1b1769cf0c9af1d6b556f8900b324e61dccb01997a2671f4bca50
+EBUILD ansi2html-1.3.0.ebuild 1094 BLAKE2B ff36ae5cb519c84847e095715acbc8f796c184bd5ffb84459673a13b5be148a369a8e62a8a8dfbd79a02282441b0600b0f850898ba2b9f5358d0a8540607ab6e SHA512 8fd63d08b0ef65e325a21e0b18fd04abd99a6f15c3bfd7fc3a7e7b5a443148811b7e95c69a0e0c3d3fbd676853fd6193531e771470a486b0ebf200baac0d9aac
MISC metadata.xml 392 BLAKE2B 13621595cc083a069522c51b4e29b362f7217698c194d5247d73a3acdaca7ca8b13a3afb0e9b0671785ce246219d44bd8511c5ef243111d43067b138635f5963 SHA512 a17684f5bd76762a832cba99a1edcd2b2ebb1abdd27f36528fb4d2ded639b6223f60495c6dd2ee548826f3a2e177238318c02962d2300ace37eaa881e76cf095
diff --git a/dev-python/ansi2html/ansi2html-1.3.0.ebuild b/dev-python/ansi2html/ansi2html-1.3.0.ebuild
new file mode 100644
index 000000000000..e8c9113901fd
--- /dev/null
+++ b/dev-python/ansi2html/ansi2html-1.3.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert text with ANSI color codes to HTML"
+HOMEPAGE="https://pypi.python.org/pypi/ansi2html https://github.com/ralphbean/ansi2html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc test"
+
+# They miserably fail.
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
+DEPEND="
+ doc? ( app-text/asciidoc )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+
+src_compile() {
+ use doc && emake man/${PN}.1
+ distutils-r1_src_compile
+}
+
+python_test() {
+ chmod -x "${S}"/tests/* || die
+ esetup.py check
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && doman man/${PN}.1
+ DOCS=( README.rst man/${PN}.1.txt )
+ distutils-r1_python_install_all
+}