summaryrefslogtreecommitdiff
path: root/dev-python/ansi2html/ansi2html-1.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-11 23:23:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-11 23:23:25 +0000
commit8e95bde8579d855189ccca3e693b4e3792f136c2 (patch)
tree4202dc7a3017eba106e5c5c5a41bcb3d08281143 /dev-python/ansi2html/ansi2html-1.9.1.ebuild
parent25e5a6599437664a3eff8d9f8a966adc896e09e8 (diff)
gentoo auto-resync : 11:12:2023 - 23:23:25
Diffstat (limited to 'dev-python/ansi2html/ansi2html-1.9.1.ebuild')
-rw-r--r--dev-python/ansi2html/ansi2html-1.9.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ansi2html/ansi2html-1.9.1.ebuild b/dev-python/ansi2html/ansi2html-1.9.1.ebuild
new file mode 100644
index 000000000000..9cfb2258e2e1
--- /dev/null
+++ b/dev-python/ansi2html/ansi2html-1.9.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Convert text with ANSI color codes to HTML"
+HOMEPAGE="
+ https://pypi.org/project/ansi2html/
+ https://github.com/pycontribs/ansi2html/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest