summaryrefslogtreecommitdiff
path: root/dev-python/ansi2html/ansi2html-1.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/ansi2html/ansi2html-1.7.0.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/ansi2html/ansi2html-1.7.0.ebuild')
-rw-r--r--dev-python/ansi2html/ansi2html-1.7.0.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/ansi2html/ansi2html-1.7.0.ebuild b/dev-python/ansi2html/ansi2html-1.7.0.ebuild
index ca696089677e..64ae09c0f98d 100644
--- a/dev-python/ansi2html/ansi2html-1.7.0.ebuild
+++ b/dev-python/ansi2html/ansi2html-1.7.0.ebuild
@@ -32,6 +32,13 @@ BDEPEND="
distutils_enable_tests --install pytest
+src_prepare() {
+ # Workaround man page compilation issue with removed setup.py file
+ # https://bugs.gentoo.org/841134
+ echo '.PHONY: setup.py' >> Makefile
+ eapply_user
+}
+
python_install_all() {
use doc && doman man/${PN}.1
distutils-r1_python_install_all
@@ -39,6 +46,6 @@ python_install_all() {
src_compile() {
# Upstream https://github.com/pycontribs/ansi2html/issues/124
- use doc && emake man/ansi2html.1
+ use doc && emake _MANUAL_VERSION="${PV}" man/ansi2html.1
distutils-r1_src_compile
}