summaryrefslogtreecommitdiff
path: root/dev-python/aniso8601
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/aniso8601
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/aniso8601')
-rw-r--r--dev-python/aniso8601/Manifest7
-rw-r--r--dev-python/aniso8601/aniso8601-1.3.0.ebuild22
-rw-r--r--dev-python/aniso8601/aniso8601-3.0.0.ebuild22
-rw-r--r--dev-python/aniso8601/aniso8601-3.0.2.ebuild22
-rw-r--r--dev-python/aniso8601/metadata.xml12
5 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/aniso8601/Manifest b/dev-python/aniso8601/Manifest
new file mode 100644
index 000000000000..8cb8c61c6542
--- /dev/null
+++ b/dev-python/aniso8601/Manifest
@@ -0,0 +1,7 @@
+DIST aniso8601-1.3.0.tar.gz 57730 BLAKE2B 7844add7f785371f69a8a473c0706edb76f994fccc99ae2cce3b56cd3a55041364bd08848acbd606453f4b8bfa3a80d063fc86ed49155817dc9fb8b7024c8e73 SHA512 33054b3bb07c26fda4af09c606dfa90be1fdebaa49efa8f508df72d339eb8f8b525ac2bad5d410098bbf1c88483823ad663649cf32f2806a9ee6e9ad46d53e8f
+DIST aniso8601-3.0.0.tar.gz 69371 BLAKE2B 7dabeb013df414db6ade982595cb95514eb408855641ac2a6552f4ab1e646d478c2435a2b1537149fcbcffa076a913b45b644163585377cf98036d898ed1154c SHA512 bea2b9dad8f8ac2c5314570ce49846ef0cdf6459019065b5529966fbaf20a79d76b7af5a93f5bb8e1d811d3355a217877ae90d295529f3e9a7b2b20e6465b1c7
+DIST aniso8601-3.0.2.tar.gz 69520 BLAKE2B 84cc774b72b04055fb7fe79456fa8c47b7ca3b2406dbbee5022912bf13bbe3663fc67ea663ba4654d27362df5bba6b9ce811ca89fc919fae9c0f5732087c43d4 SHA512 c367a9f783fc5e18bd761ce501ee7331cfd2b3f209578f90a16817ef47a16c45ea7ddc0ece648bcf91cc9e249f8f01b8d63fd1fd4bfa585bf2d959a4a12a3d6f
+EBUILD aniso8601-1.3.0.ebuild 641 BLAKE2B 8515ee81caa256f7e91698d3850df6f6523395ffff87516bd07e07e3b258681cd4f23d72e1c0bfad691337d78d6fed271c5d0f07a5cd3464517a64fe455213fb SHA512 8cf2226561a9e90ab2a34ab253e20b2cc029742bc5e3c4dab9aac098e03232c11260e5fcbbfe804c60ec68abe39ee6ab8062b3e5472e6261538dc61821b918cb
+EBUILD aniso8601-3.0.0.ebuild 643 BLAKE2B 2727e17acd6c638dc698b84afa630c05da6dcd28e989deb28ed4e47331fb4408f117f79cdbdf717a1242d36041da4e3e2fea6ff197bd1a02a5765032bd324157 SHA512 5dc7a3beb4dc57ab2f3ffdfc6b8a72f984182f6e1cb11ce45a3aa65cf01a07aeffacb1719a6fcebe199e2c3e7e7ec4f378cae825beb9ed11b3aee9c7ab1c6f3b
+EBUILD aniso8601-3.0.2.ebuild 643 BLAKE2B 2727e17acd6c638dc698b84afa630c05da6dcd28e989deb28ed4e47331fb4408f117f79cdbdf717a1242d36041da4e3e2fea6ff197bd1a02a5765032bd324157 SHA512 5dc7a3beb4dc57ab2f3ffdfc6b8a72f984182f6e1cb11ce45a3aa65cf01a07aeffacb1719a6fcebe199e2c3e7e7ec4f378cae825beb9ed11b3aee9c7ab1c6f3b
+MISC metadata.xml 385 BLAKE2B 665a2f5886166953707e75ee9f5bc225154157431ae9a9b6bb7cbcb8103150753a848ff184100c73177f40f6c5b11f1ccb4d0037504d67513810cd6dac8a1f34 SHA512 43b38fe6bef338dd41825197e7d3d0bfd3f040ce52073a6db93592f1b49bea4141a58ecc55e71b742c498a62000a2666c456b08d15bf25888858dce310e38121
diff --git a/dev-python/aniso8601/aniso8601-1.3.0.ebuild b/dev-python/aniso8601/aniso8601-1.3.0.ebuild
new file mode 100644
index 000000000000..0b1ad580e380
--- /dev/null
+++ b/dev-python/aniso8601/aniso8601-1.3.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for parsing ISO 8601 strings"
+HOMEPAGE="https://bitbucket.org/nielsenb/aniso8601/ https://pypi.org/project/aniso8601/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" -m unittest discover ${PN}/tests || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/aniso8601/aniso8601-3.0.0.ebuild b/dev-python/aniso8601/aniso8601-3.0.0.ebuild
new file mode 100644
index 000000000000..7bdae256c6d5
--- /dev/null
+++ b/dev-python/aniso8601/aniso8601-3.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for parsing ISO 8601 strings"
+HOMEPAGE="https://bitbucket.org/nielsenb/aniso8601/ https://pypi.org/project/aniso8601/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" -m unittest discover ${PN}/tests || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/aniso8601/aniso8601-3.0.2.ebuild b/dev-python/aniso8601/aniso8601-3.0.2.ebuild
new file mode 100644
index 000000000000..7bdae256c6d5
--- /dev/null
+++ b/dev-python/aniso8601/aniso8601-3.0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for parsing ISO 8601 strings"
+HOMEPAGE="https://bitbucket.org/nielsenb/aniso8601/ https://pypi.org/project/aniso8601/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" -m unittest discover ${PN}/tests || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/aniso8601/metadata.xml b/dev-python/aniso8601/metadata.xml
new file mode 100644
index 000000000000..3543616a84e9
--- /dev/null
+++ b/dev-python/aniso8601/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">aniso8601</remote-id>
+ <remote-id type="bitbucket">nielsenb/aniso8601</remote-id>
+ </upstream>
+</pkgmetadata>