summaryrefslogtreecommitdiff
path: root/dev-python/amqplib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/amqplib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/amqplib')
-rw-r--r--dev-python/amqplib/Manifest5
-rw-r--r--dev-python/amqplib/amqplib-1.0.2-r1.ebuild40
-rw-r--r--dev-python/amqplib/files/amqplib-0.6.1_disable_socket_tests.patch17
-rw-r--r--dev-python/amqplib/files/amqplib-1.0.2-unicode_tests_py3.patch63
-rw-r--r--dev-python/amqplib/metadata.xml16
5 files changed, 141 insertions, 0 deletions
diff --git a/dev-python/amqplib/Manifest b/dev-python/amqplib/Manifest
new file mode 100644
index 000000000000..fdc40dbe38cf
--- /dev/null
+++ b/dev-python/amqplib/Manifest
@@ -0,0 +1,5 @@
+AUX amqplib-0.6.1_disable_socket_tests.patch 652 BLAKE2B 7bb62c50f025c6b5223da2a83e68eba5b1659917f625658ad4ba1ffada8ed452348cc4db59d634d49d7b1c00e69e186abd3cf282631d008285b4df27c1dc9e48 SHA512 9808f03c281a1384c2753441355fc563663579c178e59a65140146ca670e2e90a2a486eec1760dfdf5dd0f91f522cb427094c758bac04c6f0f06b9e9c7ea2434
+AUX amqplib-1.0.2-unicode_tests_py3.patch 1943 BLAKE2B 995cc28ebd9dfd6762fbbefcf9bcc5c62bf50f78f446ffc95892c0531316a2f1db0c4a0ae5409083450a452f3ef785be4c42935f68f4e2b193a54c63d1f44f03 SHA512 8f7f0896593d5fc166de14116e6e67924e41332ae7cedf83501697fa64b847f9f6decd5bb9c6a3af6921607c0ec62b972be74f961a9e616de60d50a01f8ed482
+DIST amqplib-1.0.2.tgz 58544 BLAKE2B fed0cc178042467ae4e73d197dd1f2819725236274aa5951d67f7277825b851425712c96b5b1fd95010e47310746bc5b903f8858777f8999a9d310b675d60a11 SHA512 6c8c9fd7fd68fd6a1eb944962094e57f89525bc78dd002dc0dadd491b262293367a86569dfc52f0701723b4327b7c290150dc2e69e3ac1a28613578d9e0d0710
+EBUILD amqplib-1.0.2-r1.ebuild 867 BLAKE2B 9fe2d4466678e4e5b1a40ebbe4eb61d1df588dba7682fb05ca10b7645a5ecb6ec221e9c3147758dfd991b7560042a542016053ad7322f224d6cbe5d5f09cc726 SHA512 ec7cc6ea2fadf5d052ddeaf45270599033caa63a077045bd6d01b04c7bc3b12651ba2953d2fb51bff6d8d15e5be8fd20211ddbd86fb9a8e3583280edfd1597b5
+MISC metadata.xml 485 BLAKE2B fca427e3d8c4fc624fcb356fc94bdbbf89ad5ace792bb91a47248503f340e3426f1cb524c94ed1c0dd0514561a42a04fa4d89d37783400c9cca214d240883c8d SHA512 95c41cbe50f47f275c9e746bc7a7a90ecc63d17f02d7f94dd0eec0cc58de3ef8083a5f96cde53dd284e4ca0c218789b36766d798ba63ad0064838e308431e3ac
diff --git a/dev-python/amqplib/amqplib-1.0.2-r1.ebuild b/dev-python/amqplib/amqplib-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..9089dbc95bfb
--- /dev/null
+++ b/dev-python/amqplib/amqplib-1.0.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for the Advanced Message Queuing Procotol (AMQP)"
+HOMEPAGE="https://barryp.org/software/py-amqplib/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tgz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="examples extras test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.6.1_disable_socket_tests.patch"
+ "${FILESDIR}/${P}-unicode_tests_py3.patch"
+)
+
+python_test() {
+ "${PYTHON}" tests/client_0_8/run_all.py \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dodoc -r docs/.
+ if use examples; then
+ docinto examples
+ dodoc -r demo/.
+ fi
+ if use extras; then
+ insinto /usr/share/${PF}
+ doins -r extras
+ fi
+}
diff --git a/dev-python/amqplib/files/amqplib-0.6.1_disable_socket_tests.patch b/dev-python/amqplib/files/amqplib-0.6.1_disable_socket_tests.patch
new file mode 100644
index 000000000000..c92e3cba64f4
--- /dev/null
+++ b/dev-python/amqplib/files/amqplib-0.6.1_disable_socket_tests.patch
@@ -0,0 +1,17 @@
+diff -uNr amqplib-0.6.1.org/tests/client_0_8/run_all.py amqplib-0.6.1/tests/client_0_8/run_all.py
+--- amqplib-0.6.1.org/tests/client_0_8/run_all.py 2011-07-06 16:21:22.000000000 -0400
++++ amqplib-0.6.1/tests/client_0_8/run_all.py 2011-07-06 16:21:38.000000000 -0400
+@@ -28,13 +28,8 @@
+ 'test_exceptions',
+ 'test_serialization',
+ 'test_basic_message',
+- 'test_connection',
+- 'test_channel',
+ ]
+
+-if sys.version_info >= (2, 5):
+- TEST_NAMES.append('test_with')
+-
+ def main():
+ suite = unittest.TestLoader().loadTestsFromNames(TEST_NAMES)
+ unittest.TextTestRunner(**settings.test_args).run(suite)
diff --git a/dev-python/amqplib/files/amqplib-1.0.2-unicode_tests_py3.patch b/dev-python/amqplib/files/amqplib-1.0.2-unicode_tests_py3.patch
new file mode 100644
index 000000000000..14252a678203
--- /dev/null
+++ b/dev-python/amqplib/files/amqplib-1.0.2-unicode_tests_py3.patch
@@ -0,0 +1,63 @@
+--- a/tests/client_0_8/test_serialization.py 2011-07-18 00:11:48.000000000 -0400
++++ b/tests/client_0_8/test_serialization.py 2012-03-02 16:54:35.000000000 -0500
+@@ -32,6 +32,18 @@
+ # Python 2.5 and lower
+ bytes = str
+
++#Unicode Strings for py3 tests
++uni_strings = {
++ 'u0100' : '\u0100',
++ 'hello' : 'hello',
++ 'a' : 'a',
++ 'another' : 'And something in unicode'
++}
++
++if hasattr(str, 'decode'):
++ for wk, wv in uni_strings.iteritems():
++ uni_strings[wk] = wv.decode("utf-8")
++
+ import settings
+
+ from amqplib.client_0_8.serialization import AMQPReader, AMQPWriter, GenericContent
+@@ -232,12 +244,12 @@
+
+ def test_shortstr_unicode(self):
+ w = AMQPWriter()
+- w.write_shortstr(u'hello')
++ w.write_shortstr(uni_strings['hello'])
+ s = w.getvalue()
+ self.assertEqualBinary(s, '\x05hello')
+
+ r = AMQPReader(s)
+- self.assertEqual(r.read_shortstr(), u'hello')
++ self.assertEqual(r.read_shortstr(),uni_strings['hello'])
+
+ def test_long_shortstr(self):
+ w = AMQPWriter()
+@@ -245,7 +257,7 @@
+
+ def test_long_shortstr_unicode(self):
+ w = AMQPWriter()
+- self.assertRaises(ValueError, w.write_shortstr, u'\u0100' * 128)
++ self.assertRaises(ValueError, w.write_shortstr, uni_strings['u0100'] * 128)
+
+
+ #
+@@ -273,7 +285,7 @@
+ self.assertEqual(r.read_longstr(), str(val))
+
+ def test_longstr_unicode(self):
+- val = u'a' * 512
++ val = uni_strings['a'] * 512
+ w = AMQPWriter()
+ w.write_longstr(val)
+ s = w.getvalue()
+@@ -324,7 +336,7 @@
+ 'foo': 7,
+ 'bar': Decimal('123345.1234'),
+ 'baz': 'this is some random string I typed',
+- 'ubaz': u'And something in unicode',
++ 'ubaz': uni_strings['another'],
+ 'dday_aniv': datetime(1994, 6, 6),
+ 'more': {
+ 'abc': -123,
diff --git a/dev-python/amqplib/metadata.xml b/dev-python/amqplib/metadata.xml
new file mode 100644
index 000000000000..1846993fbe99
--- /dev/null
+++ b/dev-python/amqplib/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <use>
+ <flag name="extras">Install extra tools to generate initial Python mod
+ from an AMQP XML file</flag>
+ </use>
+ <upstream>
+ <remote-id type="google-code">py-amqplib</remote-id>
+ <remote-id type="pypi">amqplib</remote-id>
+ </upstream>
+</pkgmetadata>