summaryrefslogtreecommitdiff
path: root/dev-python/alembic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-25 01:25:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-25 01:25:44 +0100
commitc25088d4fc442a7d6dc3a8d0498b43024888318d (patch)
treefdb19b6a9b3a20669ecb49f0ba8d9f435fbb4b1a /dev-python/alembic
parentd80b870c42fbe218389ffaf86f0f2a39404deca1 (diff)
gentoo auto-resync : 25:09:2024 - 01:25:44
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/Manifest2
-rw-r--r--dev-python/alembic/alembic-1.13.3.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index f8bf074b0c73..95cd7217f37c 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1,3 +1,5 @@
DIST alembic-1.13.2.tar.gz 1206463 BLAKE2B edff3a244fa37556cd656e60940d94e7df75b6c67aa4199b673851b5b06e84dbf51e53f2ac9781465aa923c0019fcd33a9c3b4da90d64f583956e390ca1f5fa7 SHA512 c4952123ba00403bb030606c736dab8d5494b01662d02914fb0d10d0c1d99b27a97cc4a800cdfa32d53870031c46e351f97815e337c71f3a0a824b6403bd75cf
+DIST alembic-1.13.3.tar.gz 1921223 BLAKE2B 25f0dcc806e5988e54f2557bce31bdb50ff94ea6a312fa71a82f61114b4b34a5a2b8003c8174d77a4e202c60d84f8cad4b61c048b093e2159a6dd85ca8f38ce1 SHA512 5661098833a4314484a6e7ea4cdea9755ed84982eaa914972265943c8b62e17d5a2831d323d238c4a37d71de61251388d43f5b419e2c592753f6bdc5fc463563
EBUILD alembic-1.13.2.ebuild 1059 BLAKE2B bbcc91dd352f0a453892f7f19160469701918718113912522eb99781d2cb31001c896afd8c32665c0042dda7cfcecfca1832cf25f8deac2269c3e440369bc7d7 SHA512 3016dbf33d7b6b8dbedc780627e24b46385e1b6b428924375359a27912849d4834f916464c8e7ed795b65bdbc941e2cbf0f1e46f13a9316dc9d66f8949018a69
+EBUILD alembic-1.13.3.ebuild 1062 BLAKE2B 53255b066cdc9a0f0f6f656f1255f9db9911c5167d23de18f762cba6f203523f3a87a2375d33752285e9ec10efedf9f4343cb9a7b12805a55aac37cb6b098709 SHA512 326ebc9001902109b3a7bc4cef661b5ac6c0fa8031422b5270ac53c16ed6a32af14b0e1520337ed49f90d474ec22d16328f7779aaa29d8c243c951fdfa5e263c
MISC metadata.xml 516 BLAKE2B 08b11ebed2913b00e0a8c0044a50e3ca7bc0e51fcad180725c90445227fed1aed58ed89b4bed58ef5c050c3eee3c19da33aabce5cd1f7835f4b560e67ccc7744 SHA512 b4afb6af57562e6065f03db71da0dbdfc9c4337e54cbaddfa257ee7bad48dbeecfaccd765901bf65279e34cf96be3975f983017858904716a36bf8c18f33db79
diff --git a/dev-python/alembic/alembic-1.13.3.ebuild b/dev-python/alembic/alembic-1.13.3.ebuild
new file mode 100644
index 000000000000..cf8af9852135
--- /dev/null
+++ b/dev-python/alembic/alembic-1.13.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="
+ https://github.com/sqlalchemy/alembic/
+ https://pypi.org/project/alembic/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ sys-libs/timezone-data
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # setup.cfg contains -p no:warnings in addopts which triggers
+ # datetime.utcfromtimestamp() deprecation warning as an error in py3.12
+ epytest -o addopts=
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}