summaryrefslogtreecommitdiff
path: root/dev-python/alembic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-21 07:51:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-21 07:51:26 +0000
commita473f013073f9c57e59e7d30f088eee89312dd0d (patch)
treed61e9b56d311b630806bf50e85fc6b6ffd6825d0 /dev-python/alembic
parent2ac4d6eef70b0af1c7380b190dd14c8df8a4b9a5 (diff)
gentoo auto-resync : 21:12:2023 - 07:51:26
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/Manifest2
-rw-r--r--dev-python/alembic/alembic-1.13.1.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index 0db4fcca9f10..367596e7580f 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1,3 +1,5 @@
DIST alembic-1.13.0.tar.gz 1208438 BLAKE2B e5e3040eecd74e6095062dac51138f91b79197af6410a451f7a7ac699f8d31d12ab4e381f8b1e9ce04fd8c897339d5074493e4ef95f294276ea5d67403504229 SHA512 c9a014fc30000a09fa69e7a56cb591000443317d0cc3576fd6bd70cab7cec29906fa48d57e40dcf12d7dd93762de0d6f395fb37c9d5c1780664555757f387262
+DIST alembic-1.13.1.tar.gz 1213288 BLAKE2B 12c01f60a564c3021b3d2ae61f220822a0ca644af5097b72a826f48d04225c441f580204680674410e6e2570b5c7ee24053024863162d7d43bc423a86cddcea6 SHA512 2a5826461bec22c2efc244dd8394d34d39ed6e3511a32e8e460057ab34f9e559d28dda4ea7e34ccd30628e889a3cb37cb156596e37dba748c12a0195d78aa678
EBUILD alembic-1.13.0.ebuild 1010 BLAKE2B 613d8d61bbbc07536b878f98f6923006f1cba1dc68ace1a07782edbb4253ab5da5026b8611e4a1dd209597deaeec5731b9667e3f338d32694401895615f6baa2 SHA512 48fea4145c4c20dee6cca468e517a4df6101aeb9458f09d9d3d062da36396902bc6b43b0150f10f863ddeff3168e1d07768e324e6a107f6f61569d1fc59f786b
+EBUILD alembic-1.13.1.ebuild 1013 BLAKE2B 4f4f1758204899f7954aca23be7182313d38e6a07c0e1f00cbdb6fd540960d9ee9d77145e84564a1955c40a7fd1e6a218c5fb12d35e5e2900cd42e483bd6d6ed SHA512 af0925c243920af0201206c01a7504fa536a61b4a23fececee85cea6bec8e0819453513ea9288c55c563c967408ecaf4d827287e8ded23da964daf3ed8473048
MISC metadata.xml 516 BLAKE2B 08b11ebed2913b00e0a8c0044a50e3ca7bc0e51fcad180725c90445227fed1aed58ed89b4bed58ef5c050c3eee3c19da33aabce5cd1f7835f4b560e67ccc7744 SHA512 b4afb6af57562e6065f03db71da0dbdfc9c4337e54cbaddfa257ee7bad48dbeecfaccd765901bf65279e34cf96be3975f983017858904716a36bf8c18f33db79
diff --git a/dev-python/alembic/alembic-1.13.1.ebuild b/dev-python/alembic/alembic-1.13.1.ebuild
new file mode 100644
index 000000000000..5d610b87ddda
--- /dev/null
+++ b/dev-python/alembic/alembic-1.13.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="
+ https://github.com/sqlalchemy/alembic/
+ https://pypi.org/project/alembic/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # setup.cfg contains -p no:warnings in addopts which triggers
+ # datetime.utcfromtimestamp() deprecation warning as an error in py3.12
+ epytest -o addopts=
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}