summaryrefslogtreecommitdiff
path: root/dev-python/aiotest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/aiotest
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/aiotest')
-rw-r--r--dev-python/aiotest/Manifest3
-rw-r--r--dev-python/aiotest/aiotest-0.3.ebuild28
-rw-r--r--dev-python/aiotest/metadata.xml11
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/aiotest/Manifest b/dev-python/aiotest/Manifest
new file mode 100644
index 000000000000..ca4b5ca1fa7d
--- /dev/null
+++ b/dev-python/aiotest/Manifest
@@ -0,0 +1,3 @@
+DIST aiotest-0.3.tar.gz 10146 SHA256 1c6e3e8d210d1a37b74b4264df26ae744d9f20762701c592c2b17b85632221f0 SHA512 6af65e283dfae1ff0f09fb09498f1a5be971daef4907c5079acc1c7ad353f4aa415e03f3fb18d9fac28c54abe35c9db917584082a56b4b43cd80cbf5fa689d59 WHIRLPOOL 6606a9151b5298a03f71eb6b6b8f4f5f21b0daae175e88951b0e0c992f79d2341d82919aa7e2d356b1938a63635596e50bf9c76341c9b32bc878d62b8ca09bd6
+EBUILD aiotest-0.3.ebuild 811 SHA256 87f92abccfa8dd513dc2bf80f00222b611c96e6436f0c691a9d29424438b1e43 SHA512 150171bf89b2720c0b382d6cbbcc6d1759db5420e003b8e627c18daca27c3c957294be187cc143d7b09ff3637eca0dd9bc2d6ef0ed06cfb58abcb4cb23e5b3ee WHIRLPOOL cb6fd1f912e7a1c2de234602d63823d50acba24be747a485aaea1f0b70fa50f771577b7ae0661f4f8250fc302629ce8d76d0e103734b161a2f99bbb3d78b9137
+MISC metadata.xml 344 SHA256 d2c722e09b3273ca44432a7f3d3ce1cede1cfe7c31ddf36b4bb6f6babce18375 SHA512 da7c8a88e3043b5148eed4f1de62acd094f7e0f791cbb7d9707a97ba5fc85a1833c9754ab3beac904ccfca500b20196999b1381a8f5bdafb5375f2c9b7689819 WHIRLPOOL 7562f9970196f0c70ec88bba6353067fde8f04dabfa337f6554875bfebd0e83f287543998a9d15f5c787a6f49ba0c8bdc2d8c41dd282a43b0fdc73546ee51bd9
diff --git a/dev-python/aiotest/aiotest-0.3.ebuild b/dev-python/aiotest/aiotest-0.3.ebuild
new file mode 100644
index 000000000000..716fa573f86e
--- /dev/null
+++ b/dev-python/aiotest/aiotest-0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="Test suite for an implementation of asyncio (PEP 3156)"
+HOMEPAGE="https://bitbucket.org/haypo/aiotest"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ local suite
+ python_is_python3 && suite=asyncio || suite=trollius
+ "${PYTHON}" "test_${suite}.py" || die "Tests fail with ${EPYHON} (${suite})"
+}
diff --git a/dev-python/aiotest/metadata.xml b/dev-python/aiotest/metadata.xml
new file mode 100644
index 000000000000..4966bdb115fa
--- /dev/null
+++ b/dev-python/aiotest/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="bitbucket">haypo/aiotest</remote-id>
+ <remote-id type="pypi">aiotest</remote-id>
+ </upstream>
+</pkgmetadata>