summaryrefslogtreecommitdiff
path: root/dev-python/aiostream
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-12 00:01:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-12 00:01:15 +0100
commitd72a987a342949e200b5e9decbd71f246da53788 (patch)
treeea9d3f4ec74bd6ab18582852d7958d3f3176dfea /dev-python/aiostream
parentc035b2b83f0e94c4b2e82184f00bcef874e6276b (diff)
gentoo auto-resync : 12:05:2024 - 00:01:15
Diffstat (limited to 'dev-python/aiostream')
-rw-r--r--dev-python/aiostream/Manifest2
-rw-r--r--dev-python/aiostream/aiostream-0.6.1.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/aiostream/Manifest b/dev-python/aiostream/Manifest
index 241db072948b..82bd8576ff01 100644
--- a/dev-python/aiostream/Manifest
+++ b/dev-python/aiostream/Manifest
@@ -1,3 +1,5 @@
DIST aiostream-0.5.2.gh.tar.gz 42945 BLAKE2B 36e4f3c7834df589da3e7ec8bafb6a5b6fe40a1e868fbe0b9b81233f6721852b0e31b12144775db8785835cd5a3a0ca0a88784f7955388efd55b6ce97311b10e SHA512 282139cda0f7d08dd11af88bc3a568054906c2e0e2708f72e0ce3a67d13a44822612e3989c398ab346f8c043f17ad2e5cd2f958b1461325ad9768affec8f63fc
+DIST aiostream-0.6.1.gh.tar.gz 45466 BLAKE2B 848594d9ae191e32553dbff25ffa5926a2fd069bdc36d202f861603495ed5b33e04c4d6ae04704ca3f1d3525b73bf4f83455acc74fcfa831991c8c1ea504fe65 SHA512 0e7a87196ee7749247a6554a9347f2d8a46474db58e3793a8ac2c76b92b61e8ec7d372a05c692fcb600e81be502745ec1e7320e9dba75f50ebeff2a1ffdc35bd
EBUILD aiostream-0.5.2.ebuild 826 BLAKE2B e4d8792b5c213913b0f1e47ec23c76a5dec846c6fb31b403f2cb425c7c0bba3a81abaa143d8efbc8f38e9967fb22d9f8066611a946573961e04300209d080a4a SHA512 9ff4642a1c1c44b366c4bc9065a15f9c264175b4b67a1d1a152e320154749148d5467cb4259959a9c30a5ad90ab3c44a2ffbb7ca95c3253bc91541b46cd15e0c
+EBUILD aiostream-0.6.1.ebuild 795 BLAKE2B ede614a0444df0ceaa74db4d7b4cdd04d747cd5a2fb5ce4e8c3eafccdabb496c026724ad95d09ae24977bd41bbb180719331ef276ae46626df04da3ed129ea20 SHA512 60d15533045f285d0e66913ae94b6ec33ef8bbac8c106e21eaf91f30492eae2b913cd585621a8291eab4cad3a09cd7f416e1257a42f2c805b30c0a798b2927ac
MISC metadata.xml 396 BLAKE2B bc8d636bd40d6291341e397900882cd9791c17a3f6511740f05cd67c8fa117a1b04d5ff90ddfada0ed66dd10e72a06c4cae01ce9f5d0c005ea83509bbce264c3 SHA512 fcb085c0707495790bb7b2862b1a41e9cacdde2b06a382209f7e1e451796da4acef27761d3f32be9f9aedb95690ee26e52e93b00b963ae3fcf87441df2e90e69
diff --git a/dev-python/aiostream/aiostream-0.6.1.ebuild b/dev-python/aiostream/aiostream-0.6.1.ebuild
new file mode 100644
index 000000000000..4887cf423551
--- /dev/null
+++ b/dev-python/aiostream/aiostream-0.6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generator-based operators for asynchronous iteration"
+HOMEPAGE="
+ https://pypi.org/project/aiostream/
+ https://github.com/vxgmichel/aiostream/
+"
+SRC_URI="
+ https://github.com/vxgmichel/aiostream/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov aiostream::' \
+ pyproject.toml || die
+ distutils-r1_src_prepare
+}