summaryrefslogtreecommitdiff
path: root/dev-python/aiostream
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /dev-python/aiostream
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'dev-python/aiostream')
-rw-r--r--dev-python/aiostream/Manifest2
-rw-r--r--dev-python/aiostream/aiostream-0.6.2.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/aiostream/Manifest b/dev-python/aiostream/Manifest
index 98821f3ba294..ae90a84d2dad 100644
--- a/dev-python/aiostream/Manifest
+++ b/dev-python/aiostream/Manifest
@@ -1,3 +1,5 @@
DIST aiostream-0.6.1.gh.tar.gz 45466 BLAKE2B 848594d9ae191e32553dbff25ffa5926a2fd069bdc36d202f861603495ed5b33e04c4d6ae04704ca3f1d3525b73bf4f83455acc74fcfa831991c8c1ea504fe65 SHA512 0e7a87196ee7749247a6554a9347f2d8a46474db58e3793a8ac2c76b92b61e8ec7d372a05c692fcb600e81be502745ec1e7320e9dba75f50ebeff2a1ffdc35bd
+DIST aiostream-0.6.2.gh.tar.gz 46427 BLAKE2B fa77ccc17bff587419775785200b3640038e62b7af4187abb58f321641b524e9254a3adea7020491f4fbdab8b2f36c80eb0f430e50ff15c4f311007ad5fabce2 SHA512 572ec5281122653e2b3d3927ba6206b2c4ed975fcf64cf43aae62aed154e479902cd7ef0be274d89727cd64324dcb99389cd4cb5984a8ca646e3c43836f9f2e8
EBUILD aiostream-0.6.1.ebuild 795 BLAKE2B 7bdd02c840c9fa4ee62bdb41e8cb1bee3e4f26b2fa4a28782a561f7107dce359a92114a223b11cef3a93d10f91d33168e96869cae833bade1791dbef680b9140 SHA512 b68b21491ba94212eb7e1d8834602363c8e5d6db989a5f62a7c88b7d4cf7d2de69ff7ac3604229d4321aa96e07ea453b717faa7a7089f0e652794dc21cff02d8
+EBUILD aiostream-0.6.2.ebuild 795 BLAKE2B 7bdd02c840c9fa4ee62bdb41e8cb1bee3e4f26b2fa4a28782a561f7107dce359a92114a223b11cef3a93d10f91d33168e96869cae833bade1791dbef680b9140 SHA512 b68b21491ba94212eb7e1d8834602363c8e5d6db989a5f62a7c88b7d4cf7d2de69ff7ac3604229d4321aa96e07ea453b717faa7a7089f0e652794dc21cff02d8
MISC metadata.xml 396 BLAKE2B bc8d636bd40d6291341e397900882cd9791c17a3f6511740f05cd67c8fa117a1b04d5ff90ddfada0ed66dd10e72a06c4cae01ce9f5d0c005ea83509bbce264c3 SHA512 fcb085c0707495790bb7b2862b1a41e9cacdde2b06a382209f7e1e451796da4acef27761d3f32be9f9aedb95690ee26e52e93b00b963ae3fcf87441df2e90e69
diff --git a/dev-python/aiostream/aiostream-0.6.2.ebuild b/dev-python/aiostream/aiostream-0.6.2.ebuild
new file mode 100644
index 000000000000..6c43c63606c6
--- /dev/null
+++ b/dev-python/aiostream/aiostream-0.6.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generator-based operators for asynchronous iteration"
+HOMEPAGE="
+ https://pypi.org/project/aiostream/
+ https://github.com/vxgmichel/aiostream/
+"
+SRC_URI="
+ https://github.com/vxgmichel/aiostream/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov aiostream::' \
+ pyproject.toml || die
+ distutils-r1_src_prepare
+}