summaryrefslogtreecommitdiff
path: root/dev-python/aiostream/aiostream-0.4.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-09 15:18:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-09 15:18:13 +0000
commitf3104c28cf5ceeea12dea8aab516861d975c817d (patch)
tree0f4946a9ed67aff71917cd2dcd45cfb7d80f8eb1 /dev-python/aiostream/aiostream-0.4.5.ebuild
parent1f9ba344a5e235c6a8667384aa6ec8dd42d73889 (diff)
gentoo auto-resync : 09:12:2022 - 15:18:12
Diffstat (limited to 'dev-python/aiostream/aiostream-0.4.5.ebuild')
-rw-r--r--dev-python/aiostream/aiostream-0.4.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/aiostream/aiostream-0.4.5.ebuild b/dev-python/aiostream/aiostream-0.4.5.ebuild
new file mode 100644
index 000000000000..7e0a5fb73136
--- /dev/null
+++ b/dev-python/aiostream/aiostream-0.4.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generator-based operators for asynchronous iteration"
+HOMEPAGE="
+ https://pypi.org/project/aiostream/
+ https://github.com/vxgmichel/aiostream/
+"
+SRC_URI="
+ https://github.com/vxgmichel/aiostream/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov aiostream --cov-report html --cov-report term::' \
+ setup.cfg || die
+ distutils-r1_src_prepare
+}