summaryrefslogtreecommitdiff
path: root/dev-python/aiosmtpd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/aiosmtpd
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/aiosmtpd')
-rw-r--r--dev-python/aiosmtpd/Manifest5
-rw-r--r--dev-python/aiosmtpd/aiosmtpd-1.0.ebuild24
-rw-r--r--dev-python/aiosmtpd/aiosmtpd-1.1.ebuild24
-rw-r--r--dev-python/aiosmtpd/metadata.xml14
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/aiosmtpd/Manifest b/dev-python/aiosmtpd/Manifest
new file mode 100644
index 000000000000..b06cc666ada3
--- /dev/null
+++ b/dev-python/aiosmtpd/Manifest
@@ -0,0 +1,5 @@
+DIST aiosmtpd-1.0.tar.gz 49930 BLAKE2B 7c8f845746b51e2b77f2ff00de2c88c3a090a4cd65e55fa69fc371f8ac5a2966c31e3e7184188a1b4af1f5c3d22b7af5655c5673d199b9920865ddf56c119a06 SHA512 874b3505dd35cbb176cba058a8816329eb4177db705b10c3883f88d76e3f587efc35543812fd36a03f453c8c1ee359bb3f0239d8a246908c5c17b59be134d933
+DIST aiosmtpd-1.1.tar.gz 50722 BLAKE2B c7d21eea7816a758fb69061c0f1c4c5dbb7bd28a6daddc436211e4d8066380847255af537904ad5c09badb813269d0bc4b54dbb527b7b0c717d498c9475c8c2d SHA512 b61df616f2e14d1da67ac05149543bf48b14a31d44437d9a1dd11b166b98b56220c00e7c55e18d4fd99872d724e23f272922dd3548150632a189d9cb9b652883
+EBUILD aiosmtpd-1.0.ebuild 549 BLAKE2B 14c6ffe28a888a76e22b11eee177a78de96cfc16a23776703b49eb3e43564b2a1ead75b5e8e24170ea8cd61a5b1b68ff1caa465077a39258af7b173f7b1e9c67 SHA512 7bac181a777c81f32a89b9a22cd62f0f5ba5b2cbb287e0677cbd0cb144ea478a201a60e6dae19cabbedaeb36d3b19305b2a3ceb53d15cd0cf006737b738da439
+EBUILD aiosmtpd-1.1.ebuild 549 BLAKE2B 14c6ffe28a888a76e22b11eee177a78de96cfc16a23776703b49eb3e43564b2a1ead75b5e8e24170ea8cd61a5b1b68ff1caa465077a39258af7b173f7b1e9c67 SHA512 7bac181a777c81f32a89b9a22cd62f0f5ba5b2cbb287e0677cbd0cb144ea478a201a60e6dae19cabbedaeb36d3b19305b2a3ceb53d15cd0cf006737b738da439
+MISC metadata.xml 451 BLAKE2B 71e452a1b393808879ead1ea59d7b7a7136a39810533db9a43e1da155724ae75ff4cdfa1019fdec699fc4d4a0b7fe2291af27877a60867a63c300d4b6f089e51 SHA512 15ade72252545bff264b5504ac70210b8f8a1fc9b816b9d00bc1fbcda685efd4f1cdd6dfdd01ec27888b59d7098c0e6f64d4781a8b9ba697f4613775d0b966a1
diff --git a/dev-python/aiosmtpd/aiosmtpd-1.0.ebuild b/dev-python/aiosmtpd/aiosmtpd-1.0.ebuild
new file mode 100644
index 000000000000..8595ce17c0db
--- /dev/null
+++ b/dev-python/aiosmtpd/aiosmtpd-1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="asyncio based SMTP server"
+HOMEPAGE="http://aiosmtpd.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/atpublic[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ rm -r examples
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/aiosmtpd/aiosmtpd-1.1.ebuild b/dev-python/aiosmtpd/aiosmtpd-1.1.ebuild
new file mode 100644
index 000000000000..8595ce17c0db
--- /dev/null
+++ b/dev-python/aiosmtpd/aiosmtpd-1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="asyncio based SMTP server"
+HOMEPAGE="http://aiosmtpd.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/atpublic[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ rm -r examples
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/aiosmtpd/metadata.xml b/dev-python/aiosmtpd/metadata.xml
new file mode 100644
index 000000000000..c321fb8d48a1
--- /dev/null
+++ b/dev-python/aiosmtpd/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ A reimplementation of the Python stdlib smtpd.py based on asyncio.
+ </longdescription>
+</pkgmetadata>