summaryrefslogtreecommitdiff
path: root/dev-python/aiorpcx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-18 00:49:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-18 00:49:43 +0000
commitec33f4bcbd3944dc39c56a98cde12232684932cf (patch)
tree3f7cc55fc8e88c98187f129228aa74a73ddcb18a /dev-python/aiorpcx
parent5c94a4b3d11ad7b169e23bd604cf403c96bf4f1c (diff)
gentoo auto-resync : 18:03:2024 - 00:49:43
Diffstat (limited to 'dev-python/aiorpcx')
-rw-r--r--dev-python/aiorpcx/Manifest2
-rw-r--r--dev-python/aiorpcx/aiorpcx-0.23.1.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/aiorpcx/Manifest b/dev-python/aiorpcx/Manifest
index fc42b0cc9a9e..75f7945f6802 100644
--- a/dev-python/aiorpcx/Manifest
+++ b/dev-python/aiorpcx/Manifest
@@ -1,3 +1,5 @@
DIST aiorpcX-0.22.1.gh.tar.gz 75206 BLAKE2B 92c481388198fec94faa10482ad4195fe6dce5ae4aa445ce2812e1e81e084c629712b87a3c157aa33ae42335c1a96bdcafa5e389802740fcae8eb9e4aaf43dd2 SHA512 3484da36ce6042d8d4c6b168fd2326c0fc77a825691b95631e54510697708a27ea07e9a808445d504056432adf04f04cb0bc28d4b7194c55c1995096bb938b4d
+DIST aiorpcX-0.23.1.gh.tar.gz 70759 BLAKE2B e61aeee430670962491d165fe6841653b035b96cd07a70e6be0a0f4f5d5891859398826e4a964cd119ae7e42f2e02808363ab44b6b8f28054d86539c5067cf7b SHA512 e92f68da0783bcf66926047ab2af12b5971f4bab0a028a639e53440c9cfc39ba54ddbdd1c2a20a6dacf73dac583305f692851c0d911cd68d6aabdbe131b1a8e1
EBUILD aiorpcx-0.22.1-r1.ebuild 847 BLAKE2B 2ac8e642e5781c238629caece31cd93eaa0ae71e13c6c1546b712fdede99bbbff2a029fc224c18a07dd73a3867105eb37e6334add9ee6126a644e79ac96fc859 SHA512 b11d502f2faa742133242a81589a7370c63c4e363506946736e01e8b03ec29008280b2daf7b4aa9f4281085c7cd20ba03a92896f641ebdf3dd6118867290e5b9
+EBUILD aiorpcx-0.23.1.ebuild 850 BLAKE2B 0751986578653a9e9403ebff40b76ad853a861e87bd9f20671340b4657c9463a100fa9a6a64d78b71cbf38fed91f3174502984a1cee277596df63510541d7eda SHA512 835217879b95ca93f87ad02e3633bb02cb3c82611a1a82d66ad9baec3831ccccc150d0ce46bb2e4c1647bc988f9b5f5dfec9c70e4e63caa15658932b11afae5a
MISC metadata.xml 406 BLAKE2B 9b7f11edc470d0fe068819de2612c0505b69da7974aaa85f42f41449d33e5b3f05105c8a2419a0be96afcce6356ed483a4274bb4795531c58d30603f042e23c1 SHA512 fe0980b5d6bf46d30af528c298d6aa20bdcf49914c01e35542dcc5ddb935e3bb1ed367ce7fe9fda6bf2c348aad8c2d6158ba0f270b320f9af443a8e14ecb30a8
diff --git a/dev-python/aiorpcx/aiorpcx-0.23.1.ebuild b/dev-python/aiorpcx/aiorpcx-0.23.1.ebuild
new file mode 100644
index 000000000000..ee083de7de0a
--- /dev/null
+++ b/dev-python/aiorpcx/aiorpcx-0.23.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=aiorpcX-${PV}
+DESCRIPTION="Generic async RPC implementation, including JSON-RPC"
+HOMEPAGE="
+ https://github.com/kyuupichan/aiorpcX/
+ https://pypi.org/project/aiorpcX/
+"
+SRC_URI="
+ https://github.com/kyuupichan/aiorpcX/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/uvloop[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # require Internet
+ tests/test_socks.py::TestSOCKSProxy::test_create_connection_resolve_good
+)