summaryrefslogtreecommitdiff
path: root/dev-python/aiorpcX
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /dev-python/aiorpcX
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'dev-python/aiorpcX')
-rw-r--r--dev-python/aiorpcX/Manifest2
-rw-r--r--dev-python/aiorpcX/aiorpcX-0.18.5.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/aiorpcX/Manifest b/dev-python/aiorpcX/Manifest
index 162cbce7f549..e3d202e20f5c 100644
--- a/dev-python/aiorpcX/Manifest
+++ b/dev-python/aiorpcX/Manifest
@@ -1,4 +1,6 @@
AUX aiorpcX-0.18.4-py38.patch 1913 BLAKE2B f15e8cf86a2447944cca64e5a6e99239918e9e2971faea70bffa13a38c89ae6007bb5504fba13830a4c7dff36fda8e55953907b49421e19204c732e323cf7b34 SHA512 ff7af0ae3f9a538e36d225fef827cb4684d6fa5eccd7f24276888a538dd72f9972d643110fcba87a2f5fcf3c1d54124d85364a51ebb1a1807e608564ed72cbd1
DIST aiorpcX-0.18.4.gh.tar.gz 65500 BLAKE2B 8c84ace1e2bc974e68702e25efe126f7f69dd7451f438ccd924ee8be3c0cccc5c9b3d116bf2d0a755b013bdfe61a398d856031970e5ae82b571af09551231bed SHA512 d4df1343f575af72dff31f1794485c0cbb5b6c31d6d933b07cc8375a1418ad4fb81b2649b3c60adaaeab75b7a5d959838accc38269373310eb07895acf4c9496
+DIST aiorpcX-0.18.5.gh.tar.gz 65622 BLAKE2B 68b91e2cfb869c6971efb525fd35132c38ab9092362944fa77476bdb33f076f8415a079d97238e2c4ffbc6c9df596b468c2b6640389a11d1607b1a99aa8dc68d SHA512 5eb8417ce2ffb70208aec79e44ee0d8671c4cf86745f2d8061cf013c4ad17f83db68ed3ed43ef61df196e4ef073a21f9a4e22df46b00ce3054babf98dfcd1eaf
EBUILD aiorpcX-0.18.4-r1.ebuild 779 BLAKE2B 27da6ffd9e4a54d0a4fbc52e3a43b9b56a33d870bdf844f2641bbb2d89df39c515eb6cadf02048bbd27423591eed4dc1911ec94de05d2ce1ed03d66b4236c202 SHA512 ad38457b6891d2fcb24adc377ea8e6fa2a0431cd061b924ded6685dca46c3b514e6e1e293d8f19dc8132e88acc8ed793877059cc01c996f32ff8350750447e55
+EBUILD aiorpcX-0.18.5.ebuild 645 BLAKE2B d6e92e21169448068ad26ff659149a6a80bd445e3b556b7ee6ce9f3812f844e54b2be18950f7b9a707824a505fb534f0473082ffabdcaa703ddb7400bd79884f SHA512 cfa5801d8b99e7076dc1dede7a5babb66bfc0d01bda9ad6289ed079e9b2996a2b1df1daad929bb95821649c8495b4c75e51450df519358dc3cdab5965ce084ba
MISC metadata.xml 380 BLAKE2B c1355cf2d901123fa14fadb4f4bf084d385dfd870baa0a2189c68d05cd3bed57ae4f1caaa668211b74b6e2491e3263b99ba8b99446c0e4f5336ea06577dc540f SHA512 b025f50be4d5ba7e95f7ae7b91099498b76b75c7faa28df52f0bb64dbe55b494107f011d42bc4cd6f5c9e5786b2dc1eb8ffc8561334326dff9c99f7877576364
diff --git a/dev-python/aiorpcX/aiorpcX-0.18.5.ebuild b/dev-python/aiorpcX/aiorpcX-0.18.5.ebuild
new file mode 100644
index 000000000000..5daef298f5af
--- /dev/null
+++ b/dev-python/aiorpcX/aiorpcX-0.18.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic async RPC implementation, including JSON-RPC"
+HOMEPAGE="https://pypi.org/project/aiorpcX/
+ https://github.com/kyuupichan/aiorpcX/"
+SRC_URI="https://github.com/kyuupichan/aiorpcX/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/uvloop[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest