summaryrefslogtreecommitdiff
path: root/dev-python/aiorpcX/aiorpcX-0.19.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-04 07:37:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-04 07:37:02 +0000
commit5ae7efc9abae6bb8f8fac438298427769a91f5ad (patch)
treedc25abd0d9e2475f76b5060721ab492d2958a45f /dev-python/aiorpcX/aiorpcX-0.19.1.ebuild
parent2e6b794bf4361b8ae32bb6945e84696c2e1d94ba (diff)
gentoo auto-resync : 04:03:2023 - 07:37:01
Diffstat (limited to 'dev-python/aiorpcX/aiorpcX-0.19.1.ebuild')
-rw-r--r--dev-python/aiorpcX/aiorpcX-0.19.1.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/aiorpcX/aiorpcX-0.19.1.ebuild b/dev-python/aiorpcX/aiorpcX-0.19.1.ebuild
deleted file mode 100644
index 828fd983e277..000000000000
--- a/dev-python/aiorpcX/aiorpcX-0.19.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Generic async RPC implementation, including JSON-RPC"
-HOMEPAGE="https://pypi.org/project/aiorpcX/
- https://github.com/kyuupichan/aiorpcX/"
-SRC_URI="https://github.com/kyuupichan/aiorpcX/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-BDEPEND="
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/uvloop[${PYTHON_USEDEP}]
- dev-python/websockets[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # require Internet
- tests/test_socks.py::TestSOCKSProxy::test_create_connection_resolve_good
- )
-
- pytest -vv ${deselect[@]/#/--deselect } ||
- die "Tests failed with ${EPYTHON}"
-}