summaryrefslogtreecommitdiff
path: root/dev-python/aiorpcX/aiorpcX-0.18.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
commit7a86906b67693cc65671d3e1476835d3a7e13092 (patch)
tree9de1b9e2cf77833183d4e5ffab2e94d0403ef725 /dev-python/aiorpcX/aiorpcX-0.18.3.ebuild
parentd56d144655e3785864da43c9acb6c228ef9360ae (diff)
gentoo resync : 22.06.2019
Diffstat (limited to 'dev-python/aiorpcX/aiorpcX-0.18.3.ebuild')
-rw-r--r--dev-python/aiorpcX/aiorpcX-0.18.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/aiorpcX/aiorpcX-0.18.3.ebuild b/dev-python/aiorpcX/aiorpcX-0.18.3.ebuild
new file mode 100644
index 000000000000..b87a61bb4dd1
--- /dev/null
+++ b/dev-python/aiorpcX/aiorpcX-0.18.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic async RPC implementation, including JSON-RPC"
+HOMEPAGE="https://pypi.org/project/aiorpcX/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/attrs-17.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.rst )